<!DOCTYPE html>
<html lang="en-US" class="no-js" prefix="og: http://ogp.me/ns#">

<head prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb# article: http://ogp.me/ns/article#" typeof="og:article">
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1" />
<meta name="geo.placename" content="Vandalia"/>
<meta name="theme-color" content="#c00c00">
				<meta name="twitter:site" content="@HH_Courier" />
								<meta name="twitter:image" content="https://d31029zd06w0t6.cloudfront.net/wp-content/uploads/sites/35/2019/03/web1_Ruchaunn-Long-1-LTD.jpg" />
						<title>Warrior Way on display at blood drive - Huber Heights Courier</title>
<link rel="profile" href="https://gmpg.org/xfn/11" />
<link href='//fonts.googleapis.com/css?family=Roboto:400,700,900' rel='stylesheet' type='text/css'>

<!-- This site is optimized with the Yoast SEO plugin v5.5.1 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="HUBER HEIGHTS &#8212; The &#8220;Warrior Way&#8221; at Wayne High School means taking up a challenge, working hard, and finishing strong. That&#8217;s the"/>
<link rel="canonical" href="https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Warrior Way on display at blood drive - Huber Heights Courier" />
<meta property="og:description" content="HUBER HEIGHTS &#8212; The &#8220;Warrior Way&#8221; at Wayne High School means taking up a challenge, working hard, and finishing strong. That&#8217;s the" />
<meta property="og:url" content="https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive" />
<meta property="og:site_name" content="Huber Heights Courier" />
<meta property="article:section" content="News" />
<meta property="article:published_time" content="2019-03-05T09:53:15-05:00" />
<meta property="og:image" content="https://d31029zd06w0t6.cloudfront.net/wp-content/uploads/sites/35/2019/03/web1_Ruchaunn-Long-1-LTD.jpg" />
<meta property="og:image:secure_url" content="https://d31029zd06w0t6.cloudfront.net/wp-content/uploads/sites/35/2019/03/web1_Ruchaunn-Long-1-LTD.jpg" />
<meta property="og:image:width" content="640" />
<meta property="og:image:height" content="427" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="HUBER HEIGHTS &#8212; The &#8220;Warrior Way&#8221; at Wayne High School means taking up a challenge, working hard, and finishing strong. That&#8217;s the" />
<meta name="twitter:title" content="Warrior Way on display at blood drive - Huber Heights Courier" />
<meta name="twitter:image" content="https://d31029zd06w0t6.cloudfront.net/wp-content/uploads/sites/35/2019/03/web1_Ruchaunn-Long-1-LTD.jpg" />
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"WebSite","@id":"#website","url":"https:\/\/www.hhcourier.com\/","name":"Huber Heights Courier","potentialAction":{"@type":"SearchAction","target":"https:\/\/www.hhcourier.com\/?s={search_term_string}","query-input":"required name=search_term_string"}}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//www.hhcourier.com' />
<link rel='dns-prefetch' href='//code.jquery.com' />
<link rel='stylesheet' id='simple-staff-list-css'  href='https://d31029zd06w0t6.cloudfront.net/wp-content/plugins/simple-staff-list/public/css/simple-staff-list-public.css' type='text/css' media='all' />
<link rel='stylesheet' id='staff-list-custom-css-css'  href='https://d31029zd06w0t6.cloudfront.net/wp-content/themes/aim-dc-medium/simple-staff-list-custom.css' type='text/css' media='all' />
<link rel='stylesheet' id='vfb-pro-css'  href='https://d31029zd06w0t6.cloudfront.net/wp-content/plugins/vfb-pro/public/assets/css/vfb-style.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='noteworthy_style-css'  href='https://d31029zd06w0t6.cloudfront.net/wp-content/themes/aim-dc-medium/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='essb-userstyles-css'  href='https://d31029zd06w0t6.cloudfront.net/wp-content/easysocialsharebuttons-assets/essb-userselection.min.css' type='text/css' media='all' />
<script type='text/javascript' src='//code.jquery.com/jquery-2.2.0.min.js'></script>
<script type='text/javascript' src='https://d31029zd06w0t6.cloudfront.net/wp-content/plugins/simple-staff-list/public/js/simple-staff-list-public.js'></script>
<script type='text/javascript' src='https://d31029zd06w0t6.cloudfront.net/wp-content/themes/aim-dc-medium/library/js/modernizr-2.6.1.min.js'></script>
<script type='text/javascript' src='https://d31029zd06w0t6.cloudfront.net/wp-content/themes/aim-dc-medium/library/js/jquery.nicescroll.js'></script>
<script type='text/javascript' src='https://d31029zd06w0t6.cloudfront.net/wp-content/themes/aim-dc-medium/library/js/scripts.js'></script>
<style type="text/css">#wpadminbar #wp-admin-bar-vfbp-toolbar-edit-form > .ab-item:before {content: "\f175";top: 2px;}#wpadminbar #wp-admin-bar-vfbp-admin-toolbar > .ab-item:before {content: "\f175";top: 2px;}</style><style type="text/css">@media screen and (max-width: 750px) { .essb_links.essb_displayed_sidebar, .essb_links.essb_displayed_sidebar_right, .essb_links.essb_displayed_postfloat { display: none; } }@media screen and (max-width: 750px) { .essb-mobile-sharebar, .essb-mobile-sharepoint, .essb-mobile-sharebottom, .essb-mobile-sharebottom .essb_links, .essb-mobile-sharebar-window .essb_links, .essb-mobile-sharepoint .essb_links { display: block; } }@media screen and (max-width: 750px) { .essb-mobile-sharebar .essb_native_buttons, .essb-mobile-sharepoint .essb_native_buttons, .essb-mobile-sharebottom .essb_native_buttons, .essb-mobile-sharebottom .essb_native_item, .essb-mobile-sharebar-window .essb_native_item, .essb-mobile-sharepoint .essb_native_item { display: none; } }@media screen and (min-width: 750px) { .essb-mobile-sharebar, .essb-mobile-sharepoint, .essb-mobile-sharebottom { display: none; } }</style>
<script type="text/javascript">var essb_settings = {"ajax_url":"https:\/\/www.hhcourier.com\/wp-admin\/admin-ajax.php","essb3_nonce":"fd5aab0c8b","essb3_plugin_url":"https:\/\/www.hhcourier.com\/wp-content\/plugins\/easy-social-share-buttons3","essb3_stats":false,"essb3_ga":false,"essb3_ga_mode":"simple","blog_url":"https:\/\/www.hhcourier.com\/","essb3_postfloat_stay":false,"post_id":13003};</script>      <meta name="onesignal" content="wordpress-plugin"/>
          <link rel="manifest"
            href="https://www.hhcourier.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/manifest.json.php?gcm_sender_id="/>
          <script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js" async></script>    <script>

      window.OneSignal = window.OneSignal || [];

      OneSignal.push( function() {
        OneSignal.SERVICE_WORKER_UPDATER_PATH = "OneSignalSDKUpdaterWorker.js.php";
        OneSignal.SERVICE_WORKER_PATH = "OneSignalSDKWorker.js.php";
        OneSignal.SERVICE_WORKER_PARAM = { scope: '/' };

        OneSignal.setDefaultNotificationUrl("https://www.hhcourier.com");
        var oneSignal_options = {};
        window._oneSignalInitOptions = oneSignal_options;

        oneSignal_options['wordpress'] = true;
oneSignal_options['appId'] = 'a2f05b8a-111b-4b52-83ae-1fb37bf3ba7c';
oneSignal_options['autoRegister'] = true;
oneSignal_options['welcomeNotification'] = { };
oneSignal_options['welcomeNotification']['disable'] = true;
oneSignal_options['path'] = "https://d31029zd06w0t6.cloudfront.net/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/";
oneSignal_options['safari_web_id'] = "web.onesignal.auto.468a09a1-a4c0-43e5-8472-22975b523798";
oneSignal_options['promptOptions'] = { };
              OneSignal.init(window._oneSignalInitOptions);
                    });

      function documentInitOneSignal() {
        var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");

        var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
          oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
      }

      if (document.readyState === 'complete') {
           documentInitOneSignal();
      }
      else {
           window.addEventListener("load", function(event){
               documentInitOneSignal();
          });
      }
    </script>

<style type="text/css" id="custom-background-css">
body.custom-background { background-image: url("https://d31029zd06w0t6.cloudfront.net/wp-content/themes/aim-dc-medium/library/images/bg.jpg"); background-position: left top; background-size: auto; background-repeat: repeat; background-attachment: scroll; }
</style>
<link rel="icon" href="https://d31029zd06w0t6.cloudfront.net/wp-content/uploads/sites/35/2017/12/cropped-favicon-15-32x32.png" sizes="32x32" />
<link rel="icon" href="https://d31029zd06w0t6.cloudfront.net/wp-content/uploads/sites/35/2017/12/cropped-favicon-15-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://d31029zd06w0t6.cloudfront.net/wp-content/uploads/sites/35/2017/12/cropped-favicon-15-180x180.png" />
<meta name="msapplication-TileImage" content="https://d31029zd06w0t6.cloudfront.net/wp-content/uploads/sites/35/2017/12/cropped-favicon-15-270x270.png" />
		<script type="text/javascript" async="async" src="https://widgets.outbrain.com/outbrain.js"></script>		<script type="text/javascript">
			var _gaq = _gaq || [];
			_gaq.push(['_setAccount', 'UA-16419252-44']);
						_gaq.push(['_setCustomVar',
			  1, 
			  'Byline',
			  'Staff report',     
		   ]);
						_gaq.push(['_trackPageview']);
			(function() {
			 var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
			 ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
			 var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
			})();
		</script>
			<script type="text/javascript">
				var _qevents = _qevents || [];
				(function() {
					var elem = document.createElement('script');
					elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
					elem.async = true;
					elem.type = "text/javascript";
					var scpt = document.getElementsByTagName('script')[0];
					scpt.parentNode.insertBefore(elem, scpt);
				})();
				_qevents.push({
					qacct:"p-6dne6PYNkWEck"
				});
			</script>
			<noscript>
				<div style="display:none;">
					<img src="//pixel.quantserve.com/pixel/p-6dne6PYNkWEck.gif" border="0" height="1" width="1" alt="Quantcast"/>
				</div>
			</noscript>
						  <!-- *** Zoomd: Widget Script *** --> 
				<script async="async" src="//zdwidget3-bs.sphereup.com/zoomd/SearchUi/Script?clientId=32444253"></script>
				<!-- *** /Zoomd *** -->
			<style>
#content::before {
background-color:#c00c00 !important;
}
#content .item {
background-color:#c00c00 !important;	
}
</style>
</head>
	<body data-rsssl=1 class="post-template-default single single-post postid-13003 single-format-standard custom-background">
<div id="wrapper">

    <header id="branding" role="banner">
      
      <div id="inner-header" class="clearfix" style="margin-bottom:30px;">
	  <div id="masthead" style="float:left; margin-top:26px;"><a href="/" title="Return to Homepage" style="color:white; font-family:Roboto, Sans Serif;"><img src="https://d31029zd06w0t6.cloudfront.net/wp-content/uploads/sites/35/2016/05/HHC.png" style="max-width:300px; max-height:50px;" alt="masthead / logo"></a>
	  <br>
		<div id="tlclasswidget" style="width:350px;padding-top:10px;">
		<div id="widgetcontent" class="widgetborder">
			<a style="color:#ffffff; font-size:15px;text-decoration:none;font-weight:700;" href="http://www.jobmatchohio.com/" target="_blank" title="Huber Heights Courier Job Match"><span class="glyphicon glyphicon-briefcase"></span>Jobs</a>&nbsp;
			<a style="color:#ffffff; font-size:15px;text-decoration:none;font-weight:700;" href="/classifieds" title="Classifieds"><span class="glyphicon glyphicon-briefcase"></span>Classifieds</a>&nbsp;
						<a style="color:#ffffff; font-size:15px;text-decoration:none;font-weight:700;" href="/subscribe" title="Subscribe"><span class="glyphicon glyphicon-briefcase"></span>Subscribe</a>&nbsp;
									<a style="color:#ffffff; font-size:15px;text-decoration:none;font-weight:700;" href="http://hhcourier.oh.newsmemory.com/" target="_blank" title="E-Edition"><span class="glyphicon glyphicon-briefcase"></span>E-Edition</a>&nbsp;
															<!--<span style="color:#ffffff; font-size:15px;">Apps:</span>
			<a style="color:#ffffff; font-size:15px;" href="" target="_blank" title="Android App"> Android</a>&nbsp;
			<a style="color:#ffffff; font-size:15px;" href="" target="_blank" title="Android App">iPhone/iPad</a>&nbsp;-->
			<!--<a style="color:#ffffff;" href="https://heartlol.admanagerpro.com:8195/AMPLinersOnlineWILKESBARRE/Group.do" title="Place a Classified Ad With the Times Leader"><img src="https://d31029zd06w0t6.cloudfront.net/images/class_placead.png" alt="Place a Classified Ad With The Times Leader">Place Ad</a>-->
		</div>
	</div>
	  </div>
        	<div style="text-align:center; float:left; padding-top:25px; padding-left:10px;">
<!-- DC Code -->
								<div
				class='dfw-unit'
					data-adunit='OH-ROS-728x90-header'
					data-size-mapping='mapping1'></div>	</div>


    
        <nav id="access" role="navigation">
            <span class="assistive-text section-heading">Main menu</span>
            <div class="skip-link screen-reader-text"><a href="#content" title="Skip to content">Skip to content</a></div>
            <div class="menu"><ul id="menu-main-menu" class="menu"><li id="menu-item-4843" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-4843"><a href="/">Home</a>
<ul  class="sub-menu">
	<li id="menu-item-4851" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4851"><a href="https://www.hhcourier.com/about-us">About Us</a></li>
	<li id="menu-item-4852" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4852"><a href="https://www.hhcourier.com/advertise">Advertise</a></li>
	<li id="menu-item-4853" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4853"><a href="https://www.hhcourier.com/contact-us">Contact Us</a></li>
	<li id="menu-item-4857" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4857"><a href="https://www.facebook.com/HuberHeightsCourier">Huber Heights Courier on Facebook</a></li>
	<li id="menu-item-4858" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4858"><a href="http://twitter.com/HH_Courier">Huber Heights Courier on Twitter</a></li>
	<li id="menu-item-4854" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4854"><a href="https://www.hhcourier.com/reader-services">Reader Services</a></li>
	<li id="menu-item-4855" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4855"><a href="https://www.hhcourier.com/sign-up-for-notices">Sign Up For Notices</a></li>
	<li id="menu-item-4856" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4856"><a href="https://www.hhcourier.com/subscribe">Subscribe</a></li>
</ul>
</li>
<li id="menu-item-4844" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-4844"><a href="https://www.hhcourier.com/category/news">News</a>
<ul  class="sub-menu">
	<li id="menu-item-9850" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-9850"><a href="https://www.hhcourier.com/category/news">Latest News</a></li>
	<li id="menu-item-4859" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4859"><a href="https://www.hhcourier.com/archives">Archives</a></li>
	<li id="menu-item-4862" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4862"><a href="https://www.hhcourier.com/formnewstip">Submit News Tip</a></li>
	<li id="menu-item-4863" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4863"><a href="https://www.hhcourier.com/online-community">Online Community</a></li>
	<li id="menu-item-4864" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4864"><a href="https://www.hhcourier.com/onlineforms">Online Forms</a></li>
	<li id="menu-item-4865" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4865"><a href="https://www.hhcourier.com/specialsections">Special Sections</a></li>
	<li id="menu-item-4866" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4866"><a href="https://www.hhcourier.com/subscribe">Subscribe</a></li>
</ul>
</li>
<li id="menu-item-4845" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-4845"><a href="https://www.hhcourier.com/category/sports">Sports</a>
<ul  class="sub-menu">
	<li id="menu-item-9851" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9851"><a href="https://www.hhcourier.com/category/sports">Latest Sports</a></li>
	<li id="menu-item-4868" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4868"><a href="https://www.hhcourier.com/formscores">Submit Scores</a></li>
	<li id="menu-item-4869" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4869"><a href="https://www.hhcourier.com/formsportsnews">Submit Sports News</a></li>
	<li id="menu-item-5657" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5657"><a href="http://pro32.ap.org/hhcourier">Pro32</a></li>
	<li id="menu-item-5658" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5658"><a href="http://summergames.ap.org/hhcourier">AP Olympics Coverage</a></li>
	<li id="menu-item-5659" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5659"><a href="http://racing.ap.org/hhcourier">Auto Racing</a></li>
	<li id="menu-item-5660" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5660"><a href="http://collegebasketball.ap.org/hhcourier">College Basketball</a></li>
	<li id="menu-item-5661" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5661"><a href="http://collegefootball.ap.org/hhcourier">College Football</a></li>
</ul>
</li>
<li id="menu-item-5159" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5159"><a href="http://www.legacy.com/obituaries/hhcourier/">Obituaries</a></li>
<li id="menu-item-4846" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-4846"><a href="https://www.hhcourier.com/category/opinion">Opinion</a>
<ul  class="sub-menu">
	<li id="menu-item-9852" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9852"><a href="https://www.hhcourier.com/category/opinion">Latest Opinion</a></li>
	<li id="menu-item-4870" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4870"><a href="https://www.hhcourier.com/formeditor">Submit Letter To The Editor</a></li>
</ul>
</li>
<li id="menu-item-4847" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-4847"><a href="https://www.hhcourier.com/category/features">Features</a>
<ul  class="sub-menu">
	<li id="menu-item-9853" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9853"><a href="https://www.hhcourier.com/category/features">Local Features</a></li>
	<li id="menu-item-9868" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9868"><a href="https://www.hhcourier.com/category/special-sections">Special Sections</a></li>
	<li id="menu-item-5383" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5383"><a href="https://www.hhcourier.com/games">Games &#038; Puzzles</a></li>
	<li id="menu-item-4871" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4871"><a href="https://www.hhcourier.com/comics">Comics</a></li>
	<li id="menu-item-4872" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4872"><a href="https://www.hhcourier.com/contests">Contests</a></li>
	<li id="menu-item-4873" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4873"><a href="https://www.hhcourier.com/horoscopes">Horoscopes</a></li>
	<li id="menu-item-4876" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4876"><a href="https://www.hhcourier.com/formanniversary">Submit Anniversary</a></li>
	<li id="menu-item-4877" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4877"><a href="https://www.hhcourier.com/formbirth">Submit Birth</a></li>
	<li id="menu-item-4878" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4878"><a href="https://www.hhcourier.com/formbirthday">Submit Birthday</a></li>
	<li id="menu-item-4879" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4879"><a href="https://www.hhcourier.com/formengagement">Submit Engagement</a></li>
	<li id="menu-item-4880" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4880"><a href="https://www.hhcourier.com/formwedding">Submit Wedding</a></li>
</ul>
</li>
<li id="menu-item-4848" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4848"><a href="https://www.hhcourier.com/calendar">Calendar</a></li>
<li id="menu-item-4849" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-4849"><a href="https://www.hhcourier.com/entertainment">Entertainment</a>
<ul  class="sub-menu">
	<li id="menu-item-4885" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4885"><a href="https://www.hhcourier.com/tvlistings">TV Listings</a></li>
	<li id="menu-item-4886" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4886"><a href="https://www.hhcourier.com/tvnews">TV News</a></li>
	<li id="menu-item-4888" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4888"><a href="https://www.hhcourier.com/tvsports">TV Sports</a></li>
	<li id="menu-item-4883" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4883"><a href="https://www.hhcourier.com/tvsoaps">Soaps</a></li>
	<li id="menu-item-4881" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4881"><a href="https://www.hhcourier.com/tvmovies">Movies</a></li>
	<li id="menu-item-4882" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4882"><a href="https://www.hhcourier.com/tvqa">Q &#038; A</a></li>
	<li id="menu-item-4884" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4884"><a href="https://www.hhcourier.com/tvbestbets">TV Best Bets</a></li>
	<li id="menu-item-4887" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4887"><a href="https://www.hhcourier.com/tvsearch">TV Search</a></li>
	<li id="menu-item-4889" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4889"><a href="https://www.hhcourier.com/tvtalk">TV Talk</a></li>
	<li id="menu-item-4890" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4890"><a href="https://www.hhcourier.com/tvvideo">TV Video</a></li>
</ul>
</li>
<li id="menu-item-4850" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4850"><a href="http://local.hhcourier.com">Businesses</a></li>
</ul></div>            
        </nav><!-- #access -->
        <div id="search-icon" zoomdSearch='{"trigger":"OnClick"}'></div>
      </div>
    </header><!-- #branding -->    
    <div id="container"> 

    <div id="content" class="clearfix">
        
        <div id="main" class="col620 clearfix" role="main">

			
				<article id="post-13003" class="post-13003 post type-post status-publish format-standard has-post-thumbnail hentry category-news category-top-stories">
	<header class="entry-header">
	    	<div class="entry-meta">
			<span class="sep">Posted on </span><a href="https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive" title="9:53 am" rel="bookmark"><time class="entry-date date published" datetime="2019-03-05T09:53:15+00:00">March 5, 2019</time></a><span class="byline"> <span class="sep"> by </span> <span class="author vcard"><a class="url fn n" href="https://www.hhcourier.com/author/englewoodindependent-2-8" title="View all posts by Huber Heights Courier" rel="author">Huber Heights Courier</a></span></span>		</div><!-- .entry-meta -->
			<h1 class="entry-title">Warrior Way on display at blood drive</h1>
        <div class="item-cat">
			            <span class="cat-links">
                <a href="https://www.hhcourier.com/category/news" rel="tag">News</a>, <a href="https://www.hhcourier.com/category/top-stories" rel="tag">Top Stories</a>            </span>
                    </div>
		<br>
		<h2 style="font-family:Roboto;"></h2>
	</header><!-- .entry-header -->
    
		<div>
		<div style="float:left;">
		<b><p>Staff report</p></b>
		</div>
	</div>
	<br>
	<hr style= "color: #c00c00; background-color: #c00c00; height:2px;" />
		
	<div class="entry-content post_content">
<div class="col-sm-6 col-md-6"  style="float:left; width:300px; padding-right:5px; margin-right:10px; margin-bottom:7px;">
							<div class="thumbnail">
																<a target="popup" onclick="window.open('https://d31029zd06w0t6.cloudfront.net/wp-content/uploads/sites/35/2019/03/web1_Karla-Vallejo-NHS-advisors-AJ-Ricker-Jen-Ostendorf.jpg','Photo','width=600,height=400')" style="cursor: pointer; cursor: hand;">
				<img src="https://d31029zd06w0t6.cloudfront.net/wp-content/uploads/sites/35/2019/03/web1_Karla-Vallejo-NHS-advisors-AJ-Ricker-Jen-Ostendorf.jpg" data-toggle="modal" data-target="#myModal" alt="Wayne National Honor Society Member Karla Vallejo and NHS Advisors A.J. Ricker and Jen Ostendorf checked in donors during the Wayne High School blood drive on Feb. 25. ">
				</a>
																  <div class="caption">					
					<p style="font-family: Roboto; font-size:0.75em;">Wayne National Honor Society Member Karla Vallejo and NHS Advisors A.J. Ricker and Jen Ostendorf checked in donors during the Wayne High School blood drive on Feb. 25. </p><br>
					<p style="font-family: Roboto; font-size:0.75em;">Contributed photo </p>
				  </div>
				 			</div>
															<div class="thumbnail" style="max-width:300px;">
							<a target="popup" onclick="window.open('https://d31029zd06w0t6.cloudfront.net/wp-content/uploads/sites/35/2019/03/web1_NHS-volunteers-Coby-Beard-Colin-Turner-Kaelan-Turner-2-.jpg','Photo','width=600,height=400')" style="cursor: pointer; cursor: hand;">
				<img src="https://d31029zd06w0t6.cloudfront.net/wp-content/uploads/sites/35/2019/03/web1_NHS-volunteers-Coby-Beard-Colin-Turner-Kaelan-Turner-2-.jpg" data-toggle="modal" data-target="#myModal1">
				</a>
											  <div class="caption">					
					<p style="font-family: Roboto; font-size:0.75em;">NHS members Coby Beard, Colin Turner, and Kaelan Turner helped with snacks during the Wayne High School blood drive on Feb. 25. </p><br>
					<p style="font-family: Roboto; font-size:0.75em;">Contributed photo </p>
				  </div>
				 			</div>			
									<div class="thumbnail" style="max-width:300px;">
				<a target="popup" onclick="window.open('https://d31029zd06w0t6.cloudfront.net/wp-content/uploads/sites/35/2019/03/web1_Ruchaunn-Long-1-LTD.jpg','Photo','width=600,height=400')" style="cursor: pointer; cursor: hand;">
				<img src="https://d31029zd06w0t6.cloudfront.net/wp-content/uploads/sites/35/2019/03/web1_Ruchaunn-Long-1-LTD.jpg" data-toggle="modal" data-target="#myModal2">
				</a>
								  <div class="caption">					
					<p style="font-family: Roboto; font-size:0.75em;">Senior Ruchaunn Long, a lineman on the Warrior football team, finishes a donation during the Wayne High School blood drive on Feb. 25. </p><br>
					<p style="font-family: Roboto; font-size:0.75em;">Contributed photo </p>
				  </div>
				 			</div>			
																																											
		
	
	
	
			
																		</div>
		<article>
		<p>HUBER HEIGHTS &#8212; The &#8220;Warrior Way&#8221; at Wayne High School means taking up a challenge, working hard, and finishing strong. That&#8217;s the effort students and National Honor Society volunteers gave to their Feb. 25 blood drive, and it explains why Wayne consistently ranks among Community Blood Center&#8217;s top high school blood drives.</p>
<p>Wayne won the High School Leadership Grant for &#8220;Most Donors&#8221; in CBC&#8217;s 15-county region in 2015-2016 and ranked third in 2017-2018. Monday&#8217;s blood drive was the second of three blood drives Wayne will host this school year. It achieved 100 percent of goal with 134 donors, including 47 first-time donors and 108 donations.</p>
<p>The NHS sponsors all the Wayne blood drives and this year&#8217;s challenge included a transition to new NHS co-advisors. Wayne&#8217;s long-time blood drive coordinators Jennifer Conti and Leslie Perry passed the torch to new NHS co-advisors A.J. Ricker and Jen Ostendorf.</p>
<p>&#8220;We all learned together,&#8221; said NHS President Josiah Clark, a senior who has served as a volunteer and donated at Monday&#8217;s blood drive.</p>
<p>&#8220;We had a ton of help from both junior and senior classes,&#8221; said Josiah. &#8220;It&#8217;s a great opportunity to serve the community. We decided that we would all donate, so we were excited to do this to help the community.&#8221;</p>
<p>Their faculty advisors agreed that staging three blood drives with hundreds of students takes a team effort. Last year Wayne totaled 332 donors with 124 first-time donors, and expectations are always high.</p>
<p>&#8220;It&#8217;s a lot, especially the week leading up,&#8221; said A.J. Ricker as he checked in donors with the help of NHS volunteer Karla Vallejo. It&#8217;s definitely intense.&#8221; &#8220;It&#8217;s going really well,&#8221; said Jen Ostendorf. &#8220;We try to keep it all running smoothly!&#8221;</p>
<p>&#8220;I always wanted to do it, and I finally got the nerve to do it,&#8221; said senior Mekayla Neal as she made her first lifetime donation.</p>
<p>Senior Ruchaunn Long, a lineman on the Warrior football team, was relaxed as he stretched out his long frame on the donor bed to make his second lifetime donation. &#8220;It&#8217;s for the fun of it,&#8221; he said, &#8220;and getting out of class!&#8221;</p>
<style>
.neFileBlock {
	margin-bottom: 20px;
}
.neFileBlock p {
	margin: 0px 0px 0px 0px;
}
.neFileBlock .neFile {
	border-bottom: 1px dotted #aaa;
	padding-bottom: 5px;
	padding-top: 10px;
}
.neFileBlock .neCaption {
	font-size: 85%;
}
</style>
<div class='neFileBlock'>
<div class="neFile"><img class="neImage" src="https://d31029zd06w0t6.cloudfront.net/wp-content/uploads/sites/35/2019/03/web1_Karla-Vallejo-NHS-advisors-AJ-Ricker-Jen-Ostendorf.jpg"></p>
<div class="neCaption">Wayne National Honor Society Member Karla Vallejo and NHS Advisors A.J. Ricker and Jen Ostendorf checked in donors during the Wayne High School blood drive on Feb. 25. </div>
</div>
<div class="metaInfo"><photo0>https://www.hhcourier.com/wp-content/uploads/sites/35/2019/03/web1_Karla-Vallejo-NHS-advisors-AJ-Ricker-Jen-Ostendorf.jpg</photo0><caption0>Wayne National Honor Society Member Karla Vallejo and NHS Advisors A.J. Ricker and Jen Ostendorf checked in donors during the Wayne High School blood drive on Feb. 25. </caption0><photoCredit0>Contributed photo </photoCredit0></div>
<div class="neFile"><img class="neImage" src="https://d31029zd06w0t6.cloudfront.net/wp-content/uploads/sites/35/2019/03/web1_NHS-volunteers-Coby-Beard-Colin-Turner-Kaelan-Turner-2-.jpg"></p>
<div class="neCaption">NHS members Coby Beard, Colin Turner, and Kaelan Turner helped with snacks during the Wayne High School blood drive on Feb. 25. </div>
</div>
<div class="metaInfo"><photo1>https://www.hhcourier.com/wp-content/uploads/sites/35/2019/03/web1_NHS-volunteers-Coby-Beard-Colin-Turner-Kaelan-Turner-2-.jpg</photo1><caption1>NHS members Coby Beard, Colin Turner, and Kaelan Turner helped with snacks during the Wayne High School blood drive on Feb. 25. </caption1><photoCredit1>Contributed photo </photoCredit1></div>
<div class="neFile"><img class="neImage" src="https://d31029zd06w0t6.cloudfront.net/wp-content/uploads/sites/35/2019/03/web1_Ruchaunn-Long-1-LTD.jpg"></p>
<div class="neCaption">Senior Ruchaunn Long, a lineman on the Warrior football team, finishes a donation during the Wayne High School blood drive on Feb. 25. </div>
</div>
<div class="metaInfo"><photo2>https://www.hhcourier.com/wp-content/uploads/sites/35/2019/03/web1_Ruchaunn-Long-1-LTD.jpg</photo2><caption2>Senior Ruchaunn Long, a lineman on the Warrior football team, finishes a donation during the Wayne High School blood drive on Feb. 25. </caption2><photoCredit2>Contributed photo </photoCredit2></div>
</div>
<div class="metaInfo"><bylineMeta></p>
<p>Staff report</p>
<p></bylineMeta></div>
<div class="essb_links essb_displayed_bottom essb_share essb_template_metro-retina essb_2132895126 essb_width_flex print-no" id="essb_displayed_bottom_2132895126" data-essb-postid="13003" data-essb-position="bottom" data-essb-button-style="button" data-essb-template="metro-retina" data-essb-counter-pos="hidden" data-essb-url="https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive" data-essb-twitter-url="https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive" data-essb-instance="2132895126"><ul class="essb_links_list"><li class="essb_item essb_link_facebook nolightbox"> <a href="https://www.facebook.com/sharer/sharer.php?u=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&t=Warrior+Way+on+display+at+blood+drive" title="" onclick="essb.window(&#39;https://www.facebook.com/sharer/sharer.php?u=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&t=Warrior+Way+on+display+at+blood+drive&#39;,&#39;facebook&#39;,&#39;2132895126&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_facebook"></span><span class="essb_network_name">Facebook</span></a></li><li class="essb_item essb_link_twitter nolightbox"> <a href="#" title="" onclick="essb.window(&#39;https://twitter.com/intent/tweet?text=Warrior+Way+on+display+at+blood+drive&amp;url=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&amp;counturl=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&#39;,&#39;twitter&#39;,&#39;2132895126&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_twitter"></span><span class="essb_network_name">Twitter</span></a></li><li class="essb_item essb_link_pinterest nolightbox"> <a href="#" title="" onclick="essb.pinterest_picker(&#39;2132895126&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_pinterest"></span><span class="essb_network_name">Pinterest</span></a></li><li class="essb_item essb_link_mail nolightbox"> <a href="#" title="" onclick="essb_open_mailform(&#39;2132895126&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_mail"></span><span class="essb_network_name">Email</span></a></li><li class="essb_item essb_link_more nolightbox"> <a href="#" title="" onclick="essb.toggle_more_popup(&#39;2132895126&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_more"></span><span class="essb_network_name essb_noname"></span></a></li></ul></div><div class="essb_morepopup essb_morepopup_2132895126 essb_morepopup_bottom" style="display:none;"> <a href="#" class="essb_morepopup_close" onclick="essb.toggle_less_popup('2132895126'); return false;"><i class="essb_icon_close"></i></a> <div class="essb_morepopup_content essb_morepopup_content_2132895126"><div class="essb_links essb_displayed_more_popup essb_share essb_template_metro-retina essb_426505269 essb_width_columns_3 print-no" id="essb_displayed_more_popup_426505269" data-essb-postid="13003" data-essb-position="more_popup" data-essb-button-style="button" data-essb-template="metro-retina" data-essb-counter-pos="left" data-essb-url="https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive" data-essb-twitter-url="https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive" data-essb-instance="426505269"><ul class="essb_links_list"><li class="essb_item essb_link_facebook nolightbox"> <a href="https://www.facebook.com/sharer/sharer.php?u=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&t=Warrior+Way+on+display+at+blood+drive" title="" onclick="essb.window(&#39;https://www.facebook.com/sharer/sharer.php?u=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&t=Warrior+Way+on+display+at+blood+drive&#39;,&#39;facebook&#39;,&#39;426505269&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_facebook"></span><span class="essb_network_name">Facebook</span></a></li><li class="essb_item essb_link_twitter nolightbox"> <a href="#" title="" onclick="essb.window(&#39;https://twitter.com/intent/tweet?text=Warrior+Way+on+display+at+blood+drive&amp;url=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&amp;counturl=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&#39;,&#39;twitter&#39;,&#39;426505269&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_twitter"></span><span class="essb_network_name">Twitter</span></a></li><li class="essb_item essb_link_google nolightbox"> <a href="https://plus.google.com/share?url=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive" title="" onclick="essb.window(&#39;https://plus.google.com/share?url=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&#39;,&#39;google&#39;,&#39;426505269&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_google"></span><span class="essb_network_name">Google+</span></a></li><li class="essb_item essb_link_pinterest nolightbox"> <a href="#" title="" onclick="essb.pinterest_picker(&#39;426505269&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_pinterest"></span><span class="essb_network_name">Pinterest</span></a></li><li class="essb_item essb_link_linkedin nolightbox"> <a href="https://www.linkedin.com/shareArticle?mini=true&amp;ro=true&amp;trk=EasySocialShareButtons&amp;title=Warrior+Way+on+display+at+blood+drive&amp;url=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive" title="" onclick="essb.window(&#39;https://www.linkedin.com/shareArticle?mini=true&amp;ro=true&amp;trk=EasySocialShareButtons&amp;title=Warrior+Way+on+display+at+blood+drive&amp;url=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&#39;,&#39;linkedin&#39;,&#39;426505269&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_linkedin"></span><span class="essb_network_name">LinkedIn</span></a></li><li class="essb_item essb_link_digg nolightbox"> <a href="http://digg.com/submit?phase=2amp;url=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&amp;title=Warrior+Way+on+display+at+blood+drive" title="" onclick="essb.window(&#39;http://digg.com/submit?phase=2amp;url=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&amp;title=Warrior+Way+on+display+at+blood+drive&#39;,&#39;digg&#39;,&#39;426505269&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_digg"></span><span class="essb_network_name">Digg</span></a></li><li class="essb_item essb_link_del nolightbox"> <a href="https://del.icio.us/login?log=out&provider=essb&title=Warrior+Way+on+display+at+blood+drive&url=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&v=5" title="" onclick="essb.window(&#39;https://del.icio.us/login?log=out&provider=essb&title=Warrior+Way+on+display+at+blood+drive&url=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&v=5&#39;,&#39;del&#39;,&#39;426505269&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_del"></span><span class="essb_network_name">Del</span></a></li><li class="essb_item essb_link_stumbleupon nolightbox"> <a href="http://www.stumbleupon.com/badge/?url=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive" title="" onclick="essb.window(&#39;http://www.stumbleupon.com/badge/?url=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&#39;,&#39;stumbleupon&#39;,&#39;426505269&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_stumbleupon"></span><span class="essb_network_name">StumbleUpon</span></a></li><li class="essb_item essb_link_tumblr nolightbox"> <a href="http://tumblr.com/share?s=&v=3&t=Warrior+Way+on+display+at+blood+drive&u=https%3A%2F%2Fwww.hhcourier.com%2Fnews%2F13003%2Fwarrior-way-on-display-at-blood-drive" title="" onclick="essb.window(&#39;http://tumblr.com/share?s=&v=3&t=Warrior+Way+on+display+at+blood+drive&u=https%3A%2F%2Fwww.hhcourier.com%2Fnews%2F13003%2Fwarrior-way-on-display-at-blood-drive&#39;,&#39;tumblr&#39;,&#39;426505269&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_tumblr"></span><span class="essb_network_name">Tumblr</span></a></li><li class="essb_item essb_link_vk nolightbox"> <a href="http://vkontakte.ru/share.php?url=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive" title="" onclick="essb.window(&#39;http://vkontakte.ru/share.php?url=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&#39;,&#39;vk&#39;,&#39;426505269&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_vk"></span><span class="essb_network_name">VKontakte</span></a></li><li class="essb_item essb_link_print nolightbox"> <a href="#" title="" onclick="essb.print(&#39;426505269&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_print"></span><span class="essb_network_name">Print</span></a></li><li class="essb_item essb_link_mail nolightbox"> <a href="#" title="" onclick="essb_open_mailform(&#39;426505269&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_mail"></span><span class="essb_network_name">Email</span></a></li><li class="essb_item essb_link_flattr nolightbox"> <a href="https://flattr.com/submit/auto?user_id=&url=https%3A%2F%2Fwww.hhcourier.com%2Fnews%2F13003%2Fwarrior-way-on-display-at-blood-drive&title=Warrior%2BWay%2Bon%2Bdisplay%2Bat%2Bblood%2Bdrive&description=HUBER+HEIGHTS+%26%238212%3B+The+%26%238220%3BWarrior+Way%26%238221%3B+at+Wayne+High+School+means+taking+up+a+challenge%2C+working+hard%2C+and+finishing+strong.+That%26%238217%3Bs+the+effort+students+and+National+Honor+Society+volunteers+gave+to+their+Feb.+25+blood+drive%2C+and+it+explains+why+Wayne+consistently+ranks+among+Community+Blood+Center%26%238217%3Bs+top+high+school+blood+drives.Wayne+won+the+High+School+Leadership+Grant+for+%26%238220%3BMost+Donors%26%238221%3B+in+CBC%26%238217%3Bs+15-county+region+in+2015-2016+and+ranked+third+in+2017-2018.+Monday%26%238217%3Bs+blood+drive+was+the+second+of+three+blood+drives+Wayne+will+host+this+school+year.+It+achieved+100+percent+of+goal+with+134+donors%2C+including+47+first-time+donors+and+108+donations.The+NHS+sponsors+all+the+Wayne+blood+drives+and+this+year%26%238217%3Bs+challenge+included+a+transition+to+new+NHS+co-advisors.+Wayne%26%238217%3Bs+long-time+blood+drive+coordinators+Jennifer+Conti+and+Leslie+Perry+passed+the+torch+to+new+NHS+co-advisors+A.J.+Ricker+and+Jen+Ostendorf.%26%238220%3BWe+all+learned+together%2C%26%238221%3B+said+NHS+Pre&language=sq_AL&tags=&hidden=0&category=text" title="" onclick="essb.window(&#39;https://flattr.com/submit/auto?user_id=&url=https%3A%2F%2Fwww.hhcourier.com%2Fnews%2F13003%2Fwarrior-way-on-display-at-blood-drive&title=Warrior%2BWay%2Bon%2Bdisplay%2Bat%2Bblood%2Bdrive&description=HUBER+HEIGHTS+%26%238212%3B+The+%26%238220%3BWarrior+Way%26%238221%3B+at+Wayne+High+School+means+taking+up+a+challenge%2C+working+hard%2C+and+finishing+strong.+That%26%238217%3Bs+the+effort+students+and+National+Honor+Society+volunteers+gave+to+their+Feb.+25+blood+drive%2C+and+it+explains+why+Wayne+consistently+ranks+among+Community+Blood+Center%26%238217%3Bs+top+high+school+blood+drives.Wayne+won+the+High+School+Leadership+Grant+for+%26%238220%3BMost+Donors%26%238221%3B+in+CBC%26%238217%3Bs+15-county+region+in+2015-2016+and+ranked+third+in+2017-2018.+Monday%26%238217%3Bs+blood+drive+was+the+second+of+three+blood+drives+Wayne+will+host+this+school+year.+It+achieved+100+percent+of+goal+with+134+donors%2C+including+47+first-time+donors+and+108+donations.The+NHS+sponsors+all+the+Wayne+blood+drives+and+this+year%26%238217%3Bs+challenge+included+a+transition+to+new+NHS+co-advisors.+Wayne%26%238217%3Bs+long-time+blood+drive+coordinators+Jennifer+Conti+and+Leslie+Perry+passed+the+torch+to+new+NHS+co-advisors+A.J.+Ricker+and+Jen+Ostendorf.%26%238220%3BWe+all+learned+together%2C%26%238221%3B+said+NHS+Pre&language=sq_AL&tags=&hidden=0&category=text&#39;,&#39;flattr&#39;,&#39;426505269&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_flattr"></span><span class="essb_network_name">Flattr</span></a></li><li class="essb_item essb_link_reddit nolightbox"> <a href="http://reddit.com/submit?url=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&amp;title=Warrior+Way+on+display+at+blood+drive" title="" onclick="essb.window(&#39;http://reddit.com/submit?url=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&amp;title=Warrior+Way+on+display+at+blood+drive&#39;,&#39;reddit&#39;,&#39;426505269&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_reddit"></span><span class="essb_network_name">Reddit</span></a></li><li class="essb_item essb_link_buffer nolightbox"> <a href="https://bufferapp.com/add?url=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&text=Warrior+Way+on+display+at+blood+drive&via=&picture=&count=horizontal&source=button" title="" onclick="essb.window(&#39;https://bufferapp.com/add?url=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&text=Warrior+Way+on+display+at+blood+drive&via=&picture=&count=horizontal&source=button&#39;,&#39;buffer&#39;,&#39;426505269&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_buffer"></span><span class="essb_network_name">Buffer</span></a></li><li class="essb_item essb_link_love nolightbox"> <a href="#" title="" onclick="essb.loveThis(&#39;426505269&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_love"></span><span class="essb_network_name">Love This</span></a></li><li class="essb_item essb_link_weibo nolightbox"> <a href="http://service.weibo.com/share/share.php?url=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&title=Warrior+Way+on+display+at+blood+drive&pic=https://www.hhcourier.com/wp-content/uploads/sites/35/2019/03/web1_Ruchaunn-Long-1-LTD.jpg" title="" onclick="essb.window(&#39;http://service.weibo.com/share/share.php?url=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&title=Warrior+Way+on+display+at+blood+drive&pic=https://www.hhcourier.com/wp-content/uploads/sites/35/2019/03/web1_Ruchaunn-Long-1-LTD.jpg&#39;,&#39;weibo&#39;,&#39;426505269&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_weibo"></span><span class="essb_network_name">Weibo</span></a></li><li class="essb_item essb_link_pocket nolightbox"> <a href="https://getpocket.com/save?title=Warrior+Way+on+display+at+blood+drive&url=https%3A%2F%2Fwww.hhcourier.com%2Fnews%2F13003%2Fwarrior-way-on-display-at-blood-drive" title="" onclick="essb.window(&#39;https://getpocket.com/save?title=Warrior+Way+on+display+at+blood+drive&url=https%3A%2F%2Fwww.hhcourier.com%2Fnews%2F13003%2Fwarrior-way-on-display-at-blood-drive&#39;,&#39;pocket&#39;,&#39;426505269&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_pocket"></span><span class="essb_network_name">Pocket</span></a></li><li class="essb_item essb_link_xing nolightbox"> <a href="https://www.xing.com/social_plugins/share?h=1;url=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive" title="" onclick="essb.window(&#39;https://www.xing.com/social_plugins/share?h=1;url=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&#39;,&#39;xing&#39;,&#39;426505269&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_xing"></span><span class="essb_network_name">Xing</span></a></li><li class="essb_item essb_link_ok nolightbox"> <a href="http://www.odnoklassniki.ru/dk?st.cmd=addShare&st.s=1&st._surl=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive" title="" onclick="essb.window(&#39;http://www.odnoklassniki.ru/dk?st.cmd=addShare&st.s=1&st._surl=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&#39;,&#39;ok&#39;,&#39;426505269&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_ok"></span><span class="essb_network_name">Odnoklassniki</span></a></li><li class="essb_item essb_link_mwp nolightbox"> <a href="http://managewp.org/share/form?url=https%3A%2F%2Fwww.hhcourier.com%2Fnews%2F13003%2Fwarrior-way-on-display-at-blood-drive" title="" onclick="essb.window(&#39;http://managewp.org/share/form?url=https%3A%2F%2Fwww.hhcourier.com%2Fnews%2F13003%2Fwarrior-way-on-display-at-blood-drive&#39;,&#39;mwp&#39;,&#39;426505269&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_mwp"></span><span class="essb_network_name">ManageWP.org</span></a></li><li class="essb_item essb_link_whatsapp nolightbox"> <a href="whatsapp://send?text=Warrior%20Way%20on%20display%20at%20blood%20drive%20https%3A%2F%2Fwww.hhcourier.com%2Fnews%2F13003%2Fwarrior-way-on-display-at-blood-drive" title="" onclick="essb.tracking_only('', 'whatsapp', '426505269', true);" target="_self" rel="nofollow" ><span class="essb_icon essb_icon_whatsapp"></span><span class="essb_network_name">WhatsApp</span></a></li><li class="essb_item essb_link_meneame nolightbox"> <a href="http://www.meneame.net/submit.php?url=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive" title="" onclick="essb.window(&#39;http://www.meneame.net/submit.php?url=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&#39;,&#39;meneame&#39;,&#39;426505269&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_meneame"></span><span class="essb_network_name">Meneame</span></a></li><li class="essb_item essb_link_blogger nolightbox"> <a href="https://www.blogger.com/blog_this.pyra?t&u=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&n=Warrior+Way+on+display+at+blood+drive" title="" onclick="essb.window(&#39;https://www.blogger.com/blog_this.pyra?t&u=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&n=Warrior+Way+on+display+at+blood+drive&#39;,&#39;blogger&#39;,&#39;426505269&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_blogger"></span><span class="essb_network_name">Blogger</span></a></li><li class="essb_item essb_link_amazon nolightbox"> <a href="http://www.amazon.com/gp/wishlist/static-add?u=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&t=Warrior+Way+on+display+at+blood+drive" title="" onclick="essb.window(&#39;http://www.amazon.com/gp/wishlist/static-add?u=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&t=Warrior+Way+on+display+at+blood+drive&#39;,&#39;amazon&#39;,&#39;426505269&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_amazon"></span><span class="essb_network_name">Amazon</span></a></li><li class="essb_item essb_link_yahoomail nolightbox"> <a href="http://compose.mail.yahoo.com/?body=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive" title="" onclick="essb.window(&#39;http://compose.mail.yahoo.com/?body=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&#39;,&#39;yahoomail&#39;,&#39;426505269&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_yahoomail"></span><span class="essb_network_name">Yahoo Mail</span></a></li><li class="essb_item essb_link_gmail nolightbox"> <a href="https://mail.google.com/mail/u/0/?view=cm&fs=1&su=Warrior+Way+on+display+at+blood+drive&body=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&ui=2&tf=1" title="" onclick="essb.window(&#39;https://mail.google.com/mail/u/0/?view=cm&fs=1&su=Warrior+Way+on+display+at+blood+drive&body=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&ui=2&tf=1&#39;,&#39;gmail&#39;,&#39;426505269&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_gmail"></span><span class="essb_network_name">Gmail</span></a></li><li class="essb_item essb_link_aol nolightbox"> <a href="http://webmail.aol.com/Mail/ComposeMessage.aspx?subject=Warrior+Way+on+display+at+blood+drive&body=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive" title="" onclick="essb.window(&#39;http://webmail.aol.com/Mail/ComposeMessage.aspx?subject=Warrior+Way+on+display+at+blood+drive&body=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&#39;,&#39;aol&#39;,&#39;426505269&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_aol"></span><span class="essb_network_name">AOL</span></a></li><li class="essb_item essb_link_newsvine nolightbox"> <a href="http://www.newsvine.com/_tools/seed&save?u=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&h=Warrior+Way+on+display+at+blood+drive" title="" onclick="essb.window(&#39;http://www.newsvine.com/_tools/seed&save?u=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&h=Warrior+Way+on+display+at+blood+drive&#39;,&#39;newsvine&#39;,&#39;426505269&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_newsvine"></span><span class="essb_network_name">Newsvine</span></a></li><li class="essb_item essb_link_hackernews nolightbox"> <a href="https://news.ycombinator.com/submitlink?u=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&t=Warrior+Way+on+display+at+blood+drive" title="" onclick="essb.window(&#39;https://news.ycombinator.com/submitlink?u=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&t=Warrior+Way+on+display+at+blood+drive&#39;,&#39;hackernews&#39;,&#39;426505269&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_hackernews"></span><span class="essb_network_name">HackerNews</span></a></li><li class="essb_item essb_link_evernote nolightbox"> <a href="http://www.evernote.com/clip.action?url=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&title=Warrior+Way+on+display+at+blood+drive" title="" onclick="essb.window(&#39;http://www.evernote.com/clip.action?url=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&title=Warrior+Way+on+display+at+blood+drive&#39;,&#39;evernote&#39;,&#39;426505269&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_evernote"></span><span class="essb_network_name">Evernote</span></a></li><li class="essb_item essb_link_myspace nolightbox"> <a href="https://myspace.com/post?u=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive" title="" onclick="essb.window(&#39;https://myspace.com/post?u=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&#39;,&#39;myspace&#39;,&#39;426505269&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_myspace"></span><span class="essb_network_name">MySpace</span></a></li><li class="essb_item essb_link_mailru nolightbox"> <a href="http://connect.mail.ru/share?url=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&title=Warrior+Way+on+display+at+blood+drive&description=" title="" onclick="essb.window(&#39;http://connect.mail.ru/share?url=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&title=Warrior+Way+on+display+at+blood+drive&description=&#39;,&#39;mailru&#39;,&#39;426505269&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_mailru"></span><span class="essb_network_name">Mail.ru</span></a></li><li class="essb_item essb_link_viadeo nolightbox"> <a href="https://www.viadeo.com/?url=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&amp;title=Warrior+Way+on+display+at+blood+drive" title="" onclick="essb.window(&#39;https://www.viadeo.com/?url=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&amp;title=Warrior+Way+on+display+at+blood+drive&#39;,&#39;viadeo&#39;,&#39;426505269&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_viadeo"></span><span class="essb_network_name">Viadeo</span></a></li><li class="essb_item essb_link_line nolightbox"> <a href="line://msg/text/Warrior%20Way%20on%20display%20at%20blood%20drive%20https%3A%2F%2Fwww.hhcourier.com%2Fnews%2F13003%2Fwarrior-way-on-display-at-blood-drive" title="" onclick="essb.tracking_only('', 'line', '426505269', true);" target="_self" rel="nofollow" ><span class="essb_icon essb_icon_line"></span><span class="essb_network_name">Line</span></a></li><li class="essb_item essb_link_flipboard nolightbox"> <a href="https://share.flipboard.com/bookmarklet/popout?url=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&title=Warrior+Way+on+display+at+blood+drive" title="" onclick="essb.window(&#39;https://share.flipboard.com/bookmarklet/popout?url=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&title=Warrior+Way+on+display+at+blood+drive&#39;,&#39;flipboard&#39;,&#39;426505269&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_flipboard"></span><span class="essb_network_name">Flipboard</span></a></li><li class="essb_item essb_link_comments nolightbox"> <a href="#comments" title="" onclick="essb.tracking_only('', 'comments', '426505269', true);" target="_self" rel="nofollow" ><span class="essb_icon essb_icon_comments"></span><span class="essb_network_name">Comments</span></a></li><li class="essb_item essb_link_yummly nolightbox"> <a href="http://www.yummly.com/urb/verify?url=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&title=Warrior+Way+on+display+at+blood+drive&image=https://www.hhcourier.com/wp-content/uploads/sites/35/2019/03/web1_Ruchaunn-Long-1-LTD.jpg&yumtype=button" title="" onclick="essb.window(&#39;http://www.yummly.com/urb/verify?url=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&title=Warrior+Way+on+display+at+blood+drive&image=https://www.hhcourier.com/wp-content/uploads/sites/35/2019/03/web1_Ruchaunn-Long-1-LTD.jpg&yumtype=button&#39;,&#39;yummly&#39;,&#39;426505269&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_yummly"></span><span class="essb_network_name">Yummly</span></a></li><li class="essb_item essb_link_sms nolightbox"> <a href="sms:&body=Warrior%20Way%20on%20display%20at%20blood%20drive%20https%3A%2F%2Fwww.hhcourier.com%2Fnews%2F13003%2Fwarrior-way-on-display-at-blood-drive" title="" onclick="essb.window(&#39;sms:&body=Warrior%20Way%20on%20display%20at%20blood%20drive%20https%3A%2F%2Fwww.hhcourier.com%2Fnews%2F13003%2Fwarrior-way-on-display-at-blood-drive&#39;,&#39;sms&#39;,&#39;426505269&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_sms"></span><span class="essb_network_name">SMS</span></a></li><li class="essb_item essb_link_viber nolightbox"> <a href="viber://forward?text=Warrior%20Way%20on%20display%20at%20blood%20drive%20https%3A%2F%2Fwww.hhcourier.com%2Fnews%2F13003%2Fwarrior-way-on-display-at-blood-drive" title="" onclick="essb.tracking_only('', 'viber', '426505269', true);" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_viber"></span><span class="essb_network_name">Viber</span></a></li><li class="essb_item essb_link_telegram nolightbox"> <a href="tg://msg?text=Warrior%20Way%20on%20display%20at%20blood%20drive%20https%3A%2F%2Fwww.hhcourier.com%2Fnews%2F13003%2Fwarrior-way-on-display-at-blood-drive" title="" onclick="essb.tracking_only('', 'telegram', '426505269', true);" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_telegram"></span><span class="essb_network_name">Telegram</span></a></li><li class="essb_item essb_link_subscribe nolightbox"> <a href="#" title="" onclick="essb.toggle_subscribe('426505269'); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_subscribe"></span><span class="essb_network_name">Subscribe</span></a></li><li class="essb_item essb_link_skype nolightbox"> <a href="https://web.skype.com/share?url=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive" title="" onclick="essb.window(&#39;https://web.skype.com/share?url=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&#39;,&#39;skype&#39;,&#39;426505269&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_skype"></span><span class="essb_network_name">Skype</span></a></li><li class="essb_item essb_link_messenger nolightbox"> <a href="https://www.facebook.com/dialog/send?app_id=&link=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&redirect_uri=https://facebook.com" title="" onclick="essb.window(&#39;https://www.facebook.com/dialog/send?app_id=&link=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&redirect_uri=https://facebook.com&#39;,&#39;messenger&#39;,&#39;426505269&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_messenger"></span><span class="essb_network_name">Facebook Messenger</span></a></li><li class="essb_item essb_link_kakaotalk nolightbox"> <a href="https://story.kakao.com/share?url=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive" title="" onclick="essb.window(&#39;https://story.kakao.com/share?url=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&#39;,&#39;kakaotalk&#39;,&#39;426505269&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_kakaotalk"></span><span class="essb_network_name">Kakao</span></a></li><li class="essb_item essb_link_livejournal nolightbox"> <a href="http://www.livejournal.com/update.bml?subject=Warrior Way on display at blood drive&event=%3Ca+href%3D%22https%3A%2F%2Fwww.hhcourier.com%2Fnews%2F13003%2Fwarrior-way-on-display-at-blood-drive%22%3EWarrior+Way+on+display+at+blood+drive%3C%2Fa%3E" title="" onclick="essb.window(&#39;http://www.livejournal.com/update.bml?subject=Warrior Way on display at blood drive&event=%3Ca+href%3D%22https%3A%2F%2Fwww.hhcourier.com%2Fnews%2F13003%2Fwarrior-way-on-display-at-blood-drive%22%3EWarrior+Way+on+display+at+blood+drive%3C%2Fa%3E&#39;,&#39;livejournal&#39;,&#39;426505269&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_livejournal"></span><span class="essb_network_name">LiveJournal</span></a></li><li class="essb_item essb_link_yammer nolightbox"> <a href="https://www.yammer.com/messages/new?login=true&amp;trk_event=yammer_share&amp;status=Warrior%20Way%20on%20display%20at%20blood%20drive https%3A%2F%2Fwww.hhcourier.com%2Fnews%2F13003%2Fwarrior-way-on-display-at-blood-drive" title="" onclick="essb.window(&#39;https://www.yammer.com/messages/new?login=true&amp;trk_event=yammer_share&amp;status=Warrior%20Way%20on%20display%20at%20blood%20drive https%3A%2F%2Fwww.hhcourier.com%2Fnews%2F13003%2Fwarrior-way-on-display-at-blood-drive&#39;,&#39;yammer&#39;,&#39;426505269&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_yammer"></span><span class="essb_network_name">Yammer</span></a></li><li class="essb_item essb_link_meetedgar nolightbox"> <a href="javascript:(function()%7B!function()%7Bvar e%3Ddocument.getElementsByTagName(&quot;head&quot;)%5B0%5D,t%3Ddocument.createElement(&quot;script&quot;)%3Bt.type%3D&quot;text/javascript&quot;,t.src%3D&quot;//app.meetedgar.com/share.js%3F&quot;%2BMath.floor(99999*Math.random()),e.appendChild(t)%7D()%7D)()%3B" title="" onclick="essb.tracking_only('', 'meetedgar', '426505269', true);" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_meetedgar"></span><span class="essb_network_name">Edgar</span></a></li></ul></div></div></div> <div class="essb_morepopup_shadow essb_morepopup_shadow_2132895126" onclick="essb.toggle_less_popup('2132895126'); return false;"></div><div class="essb-subscribe-form essb-subscribe-form-426505269 essb-subscribe-form-popup" data-popup="1" style="display: none;"><button type="button" class="essb-subscribe-form-close" onclick="essb.subscribe_popup_close('426505269');">x</button></div><div class="essb-subscribe-form-overlay essb-subscribe-form-overlay-426505269" onclick="essb.subscribe_popup_close('426505269');"></div><div class="essb_break_scroll"></div>				</article>
<div align="center">
			<!-- DC Code -->
<div
				class='dfw-unit'
					data-adunit='OH-ROS-728x90-footer'
					data-size-mapping='mapping2'></div></div>
		<!--RECOMMENDED-->
		<div style="clear:both;"></div>
		  <div class="item-wrap clearfix" style="padding: 45px 8px 0;">

<div class="OUTBRAIN" data-widget-id="TF_6" data-src="https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive" data-ob-template="AIM Media Indiana Operating LLC._201806291134" ></div>
          </div>
		<!--END RECOMMENDED-->
<!-- Comment system -->
<!-- An element a visitor can click if they <3 comments! -->
<div style="margin:auto;display:block;text-align:center;">
<button class="show-comments" style="border: 1px solid #0a3c59;
   background: #3e779d;
   background: -webkit-gradient(linear, left top, left bottom, from(#65a9d7), to(#3e779d));
   background: -webkit-linear-gradient(top, #65a9d7, #3e779d);
   background: -moz-linear-gradient(top, #65a9d7, #3e779d);
   background: -ms-linear-gradient(top, #65a9d7, #3e779d);
   background: -o-linear-gradient(top, #65a9d7, #3e779d);
   background-image: -ms-linear-gradient(top, #65a9d7 0%, #3e779d 100%);
   padding: 10.5px 21px;
   -webkit-border-radius: 6px;
   -moz-border-radius: 6px;
   border-radius: 6px;
   -webkit-box-shadow: rgba(255,255,255,0.4) 0 1px 0, inset rgba(255,255,255,0.4) 0 1px 0;
   -moz-box-shadow: rgba(255,255,255,0.4) 0 1px 0, inset rgba(255,255,255,0.4) 0 1px 0;
   box-shadow: rgba(255,255,255,0.4) 0 1px 0, inset rgba(255,255,255,0.4) 0 1px 0;
   text-shadow: #7ea4bd 0 1px 0;
   color: #ffffff;
   font-size: 14px;
   font-family: helvetica, serif;
   text-decoration: none;
   vertical-align: middle;min-width:300px;">Load comments</button>
</div>
<!-- The empty element required for Disqus to loads comments into -->  
<div id="disqus_thread"></div>
<script type="text/javascript">
// Requires jQuery of course.
$(document).ready(function() {
    $('.show-comments').on('click', function(){
          var disqus_shortname = 'huberheightscourier';
          // ajax request to load the disqus javascript
          $.ajax({
                  type: "GET",
                  url: "//" + disqus_shortname + ".disqus.com/embed.js",
                  dataType: "script",
                  cache: true
          });
          // hide the button once comments load
          $(this).fadeOut();
    });
});
</script>
<!-- End comment system -->


			</div><!-- .entry-content -->

	<footer class="entry-meta">
		Bookmark the <a href="https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive" title="Permalink to Warrior Way on display at blood drive" rel="bookmark">permalink</a>.
			</footer><!-- .entry-meta -->
</article><!-- 1 #post-13003 -->

					<nav id="nav-below">
		<p class="assistive-text section-heading">Post navigation</p>

	
		<div class="nav-previous"><a href="https://www.hhcourier.com/sports/local-sports-1/12998/warriors-fall-to-emotionally-driven-firebirds" rel="prev"><span class="meta-nav">Previous</span></a></div>		
	
	</nav><!-- #nav-below -->
	
			
        </div> <!-- end #main -->

        		<div id="sidebar" class="widget-area col300" role="complementary">
		<aside id="weather" class="widget">
<a href="http://www.accuweather.com/en/us/huber-heights-oh/45424/weather-forecast/339991" class="aw-widget-legal">
<!--
By accessing and/or using this code snippet, you agree to AccuWeather’s terms and conditions (in English) which can be found at http://www.accuweather.com/en/free-weather-widgets/terms and AccuWeather’s Privacy Statement (in English) which can be found at http://www.accuweather.com/en/privacy.
-->
</a><div id="awcc1463425167767" class="aw-widget-current"  data-locationkey="339991" data-unit="f" data-language="en-us" data-useip="false" data-partner="civitas" data-uid="awcc1460129762895" data-targeturl="https://www.hhcourier.com/weather"></div><script async defer type="text/javascript" src="https://oap.accuweather.com/launch.js"></script>

<!-- DC Code -->
<div
				class='dfw-unit'
					data-adunit='OH-Weather-Sponsor-300x100'
					data-size-mapping='mapping3'></div>			</aside>
<aside>
<div
				class='dfw-unit'
					data-adunit='OH-ROS-300x600-sidebar'
					data-size-mapping='mapping4'></div></aside>

           <aside id="poll" style="margin-top:20px;">
			<h2 class="widget-title">&nbsp; Poll</a></h2>
								<script async defer type="text/javascript" src="https://www.civicscience.com/widget/jspoll/?elt=b1dbc403-e122-7704-e980-e0501f8f67b3&amp;tgtid=7f81d10b-87ae-fc24-910c-5a7646869fa7"></script>
					<div id="b1dbc403-e122-7704-e980-e0501f8f67b3"></div>
			</aside>

<aside id="social-media" style="margin-top:20px;">
            <div id="social-media" class="clearfix">
				                
                 
                   
                                                                            </div>
</aside>
		</div><!-- #sidebar .widget-area -->

    </div> <!-- end #content -->
        
    </div><!-- #container -->
</div><!-- #wrapper -->
<style>.footer-add{position:fixed;width:100%;bottom:0;min-width:906px;float:left;background-color:#101010;text-align:center;z-index:1000;}</style>
<div class="footer-add">
						<!-- DC Code -->
<div
				class='dfw-unit'
					data-adunit='OH-Sticky-Footer-1024x60'
					data-size-mapping='mapping5'></div></div>
<footer id="colophon" role="contentinfo" style="height:300px;background-color:#141414;background-image:url('https://d31029zd06w0t6.cloudfront.net/images/blue-background.png');background-repeat:no-repeat;background-size:cover;">
	<div class="item-wrap clearfix">
	<style>.group:after,.section{clear:both}.section{padding:0;margin:0}.col{display:block;float:left;margin:1% 0 1% 1.6%}.col:first-child{margin-left:0}.group:after,.group:before{content:"";display:table}.group{zoom:1}.span_5_of_5{width:100%}.span_4_of_5{width:79.68%}.span_3_of_5{width:59.36%}.span_2_of_5{width:39.04%}.span_1_of_5{width:18.72%}@media only screen and (max-width:480px){.col{margin:1% 0}.span_1_of_5,.span_2_of_5,.span_3_of_5,.span_4_of_5,.span_5_of_5{width:100%}}</style>
		<div class="section group">
			<div class="col span_1_of_5">
				
			</div>		
			<div class="col span_1_of_5">
				<a href="/privacy-policy" target="_blank" style="color:white; font-family:Roboto; text-decoration:none;">Privacy Policy</a><br>
				<a href="/advertise" style="color:white; font-family:Roboto; text-decoration:none;">Advertise With Us</a><br>
			</div>
			<div class="col span_1_of_5">
				<b><a href="http://www.publicnoticesohio.com" title="Public Notices Ohio" target="_blank" style="font-family:Droid Sans; color:#fff;">PublicNoticesOhio.com</a></b><br>
				<a href="http://huberheightscourier.mycapture.com" target="_blank" style="color:white; font-family:Roboto; text-decoration:none;">Photo Store</a><br>
				<p><a href="http://local.hhcourier.com" target="_blank" style="color:#fff; font-family:Roboto; text-decoration:none;" title="Local Business Directory">Local Business Directory</a></p>
				<span style="color:#fff; font-family:Roboto; text-decoration:none;">&copy; 2019 AIM Media Midwest</span><br>
			</div>
			<div class="col span_1_of_5">
				<style>.button{background-color:#008CBA;border:none;color:#fff;padding:15px 32px;text-align:center;text-decoration:none;display:inline-block;font-size:16px;margin:4px 2px;cursor:pointer}</style>
			<a href="https://www.facebook.com/HuberHeightsCourier" target="blank" title="Huber Heights Courier on Facebook"><img src="https://d31029zd06w0t6.cloudfront.net/images/fb.png" alt="Huber Heights Courier on Facebook"></a>&nbsp;
			<a href="http://twitter.com/HH_Courier" target="blank" title="Huber Heights Courier on Twitter"><img src="https://d31029zd06w0t6.cloudfront.net/images/tw.png" alt="Huber Heights Courier on Twitter"></a>&nbsp;
			<br>
			<a href="/sign-up-for-notices" alt="Sign Up For Notices"><button class="button">Get News Alerts</button></a><br>
			<p style="font-family:Roboto; color:#fff; text-decoration:none;"><img src="https://d31029zd06w0t6.cloudfront.net/images/footerphonewhite.png" alt="Phone" style="height:15px;"> 937-236-4990</p>
						<p style="font-family:Roboto; color:#fff;"><img src="https://d31029zd06w0t6.cloudfront.net/images/footeraddresswhite.png" alt="Address">694 W. National Road,</p>
			<p style="font-family:Roboto; color:#fff;">Vandalia OH, 45377</p>
			</div>
			<div class="col span_1_of_5">
				
			</div>
		</div>
	</div>
</footer><!-- #colophon -->
<div class="essb_links essb_displayed_sidebar essb_share essb_template_metro-retina essb_1204523492 print-no" id="essb_displayed_sidebar_1204523492" data-essb-postid="13003" data-essb-position="sidebar" data-essb-button-style="icon_hover" data-essb-template="metro-retina" data-essb-counter-pos="hidden" data-essb-url="https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive" data-essb-twitter-url="https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive" data-essb-instance="1204523492"><ul class="essb_links_list essb_hide_name"><li class="essb_item essb_link_facebook nolightbox"> <a href="https://www.facebook.com/sharer/sharer.php?u=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&t=Warrior+Way+on+display+at+blood+drive" title="" onclick="essb.window(&#39;https://www.facebook.com/sharer/sharer.php?u=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&t=Warrior+Way+on+display+at+blood+drive&#39;,&#39;facebook&#39;,&#39;1204523492&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_facebook"></span><span class="essb_network_name">Facebook</span></a></li><li class="essb_item essb_link_twitter nolightbox"> <a href="#" title="" onclick="essb.window(&#39;https://twitter.com/intent/tweet?text=Warrior+Way+on+display+at+blood+drive&amp;url=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&amp;counturl=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&#39;,&#39;twitter&#39;,&#39;1204523492&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_twitter"></span><span class="essb_network_name">Twitter</span></a></li><li class="essb_item essb_link_pinterest nolightbox"> <a href="#" title="" onclick="essb.pinterest_picker(&#39;1204523492&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_pinterest"></span><span class="essb_network_name">Pinterest</span></a></li><li class="essb_item essb_link_mail nolightbox"> <a href="#" title="" onclick="essb_open_mailform(&#39;1204523492&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_mail"></span><span class="essb_network_name">Email</span></a></li><li class="essb_item essb_link_more nolightbox"> <a href="#" title="" onclick="essb.toggle_more_popup(&#39;1204523492&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_more"></span><span class="essb_network_name essb_noname"></span></a></li></ul></div><div class="essb_morepopup essb_morepopup_1204523492 essb_morepopup_sidebar" style="display:none;"> <a href="#" class="essb_morepopup_close" onclick="essb.toggle_less_popup('1204523492'); return false;"><i class="essb_icon_close"></i></a> <div class="essb_morepopup_content essb_morepopup_content_1204523492"><div class="essb_links essb_displayed_more_popup essb_share essb_template_metro-retina essb_810833573 essb_width_columns_3 print-no" id="essb_displayed_more_popup_810833573" data-essb-postid="13003" data-essb-position="more_popup" data-essb-button-style="button" data-essb-template="metro-retina" data-essb-counter-pos="left" data-essb-url="https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive" data-essb-twitter-url="https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive" data-essb-instance="810833573"><ul class="essb_links_list"><li class="essb_item essb_link_facebook nolightbox"> <a href="https://www.facebook.com/sharer/sharer.php?u=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&t=Warrior+Way+on+display+at+blood+drive" title="" onclick="essb.window(&#39;https://www.facebook.com/sharer/sharer.php?u=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&t=Warrior+Way+on+display+at+blood+drive&#39;,&#39;facebook&#39;,&#39;810833573&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_facebook"></span><span class="essb_network_name">Facebook</span></a></li><li class="essb_item essb_link_twitter nolightbox"> <a href="#" title="" onclick="essb.window(&#39;https://twitter.com/intent/tweet?text=Warrior+Way+on+display+at+blood+drive&amp;url=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&amp;counturl=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&#39;,&#39;twitter&#39;,&#39;810833573&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_twitter"></span><span class="essb_network_name">Twitter</span></a></li><li class="essb_item essb_link_google nolightbox"> <a href="https://plus.google.com/share?url=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive" title="" onclick="essb.window(&#39;https://plus.google.com/share?url=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&#39;,&#39;google&#39;,&#39;810833573&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_google"></span><span class="essb_network_name">Google+</span></a></li><li class="essb_item essb_link_pinterest nolightbox"> <a href="#" title="" onclick="essb.pinterest_picker(&#39;810833573&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_pinterest"></span><span class="essb_network_name">Pinterest</span></a></li><li class="essb_item essb_link_linkedin nolightbox"> <a href="https://www.linkedin.com/shareArticle?mini=true&amp;ro=true&amp;trk=EasySocialShareButtons&amp;title=Warrior+Way+on+display+at+blood+drive&amp;url=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive" title="" onclick="essb.window(&#39;https://www.linkedin.com/shareArticle?mini=true&amp;ro=true&amp;trk=EasySocialShareButtons&amp;title=Warrior+Way+on+display+at+blood+drive&amp;url=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&#39;,&#39;linkedin&#39;,&#39;810833573&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_linkedin"></span><span class="essb_network_name">LinkedIn</span></a></li><li class="essb_item essb_link_digg nolightbox"> <a href="http://digg.com/submit?phase=2amp;url=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&amp;title=Warrior+Way+on+display+at+blood+drive" title="" onclick="essb.window(&#39;http://digg.com/submit?phase=2amp;url=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&amp;title=Warrior+Way+on+display+at+blood+drive&#39;,&#39;digg&#39;,&#39;810833573&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_digg"></span><span class="essb_network_name">Digg</span></a></li><li class="essb_item essb_link_del nolightbox"> <a href="https://del.icio.us/login?log=out&provider=essb&title=Warrior+Way+on+display+at+blood+drive&url=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&v=5" title="" onclick="essb.window(&#39;https://del.icio.us/login?log=out&provider=essb&title=Warrior+Way+on+display+at+blood+drive&url=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&v=5&#39;,&#39;del&#39;,&#39;810833573&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_del"></span><span class="essb_network_name">Del</span></a></li><li class="essb_item essb_link_stumbleupon nolightbox"> <a href="http://www.stumbleupon.com/badge/?url=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive" title="" onclick="essb.window(&#39;http://www.stumbleupon.com/badge/?url=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&#39;,&#39;stumbleupon&#39;,&#39;810833573&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_stumbleupon"></span><span class="essb_network_name">StumbleUpon</span></a></li><li class="essb_item essb_link_tumblr nolightbox"> <a href="http://tumblr.com/share?s=&v=3&t=Warrior+Way+on+display+at+blood+drive&u=https%3A%2F%2Fwww.hhcourier.com%2Fnews%2F13003%2Fwarrior-way-on-display-at-blood-drive" title="" onclick="essb.window(&#39;http://tumblr.com/share?s=&v=3&t=Warrior+Way+on+display+at+blood+drive&u=https%3A%2F%2Fwww.hhcourier.com%2Fnews%2F13003%2Fwarrior-way-on-display-at-blood-drive&#39;,&#39;tumblr&#39;,&#39;810833573&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_tumblr"></span><span class="essb_network_name">Tumblr</span></a></li><li class="essb_item essb_link_vk nolightbox"> <a href="http://vkontakte.ru/share.php?url=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive" title="" onclick="essb.window(&#39;http://vkontakte.ru/share.php?url=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&#39;,&#39;vk&#39;,&#39;810833573&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_vk"></span><span class="essb_network_name">VKontakte</span></a></li><li class="essb_item essb_link_print nolightbox"> <a href="#" title="" onclick="essb.print(&#39;810833573&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_print"></span><span class="essb_network_name">Print</span></a></li><li class="essb_item essb_link_mail nolightbox"> <a href="#" title="" onclick="essb_open_mailform(&#39;810833573&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_mail"></span><span class="essb_network_name">Email</span></a></li><li class="essb_item essb_link_flattr nolightbox"> <a href="https://flattr.com/submit/auto?user_id=&url=https%3A%2F%2Fwww.hhcourier.com%2Fnews%2F13003%2Fwarrior-way-on-display-at-blood-drive&title=Warrior%2BWay%2Bon%2Bdisplay%2Bat%2Bblood%2Bdrive&description=HUBER+HEIGHTS+%26%238212%3B+The+%26%238220%3BWarrior+Way%26%238221%3B+at+Wayne+High+School+means+taking+up+a+challenge%2C+working+hard%2C+and+finishing+strong.+That%26%238217%3Bs+the+effort+students+and+National+Honor+Society+volunteers+gave+to+their+Feb.+25+blood+drive%2C+and+it+explains+why+Wayne+consistently+ranks+among+Community+Blood+Center%26%238217%3Bs+top+high+school+blood+drives.Wayne+won+the+High+School+Leadership+Grant+for+%26%238220%3BMost+Donors%26%238221%3B+in+CBC%26%238217%3Bs+15-county+region+in+2015-2016+and+ranked+third+in+2017-2018.+Monday%26%238217%3Bs+blood+drive+was+the+second+of+three+blood+drives+Wayne+will+host+this+school+year.+It+achieved+100+percent+of+goal+with+134+donors%2C+including+47+first-time+donors+and+108+donations.The+NHS+sponsors+all+the+Wayne+blood+drives+and+this+year%26%238217%3Bs+challenge+included+a+transition+to+new+NHS+co-advisors.+Wayne%26%238217%3Bs+long-time+blood+drive+coordinators+Jennifer+Conti+and+Leslie+Perry+passed+the+torch+to+new+NHS+co-advisors+A.J.+Ricker+and+Jen+Ostendorf.%26%238220%3BWe+all+learned+together%2C%26%238221%3B+said+NHS+Pre&language=sq_AL&tags=&hidden=0&category=text" title="" onclick="essb.window(&#39;https://flattr.com/submit/auto?user_id=&url=https%3A%2F%2Fwww.hhcourier.com%2Fnews%2F13003%2Fwarrior-way-on-display-at-blood-drive&title=Warrior%2BWay%2Bon%2Bdisplay%2Bat%2Bblood%2Bdrive&description=HUBER+HEIGHTS+%26%238212%3B+The+%26%238220%3BWarrior+Way%26%238221%3B+at+Wayne+High+School+means+taking+up+a+challenge%2C+working+hard%2C+and+finishing+strong.+That%26%238217%3Bs+the+effort+students+and+National+Honor+Society+volunteers+gave+to+their+Feb.+25+blood+drive%2C+and+it+explains+why+Wayne+consistently+ranks+among+Community+Blood+Center%26%238217%3Bs+top+high+school+blood+drives.Wayne+won+the+High+School+Leadership+Grant+for+%26%238220%3BMost+Donors%26%238221%3B+in+CBC%26%238217%3Bs+15-county+region+in+2015-2016+and+ranked+third+in+2017-2018.+Monday%26%238217%3Bs+blood+drive+was+the+second+of+three+blood+drives+Wayne+will+host+this+school+year.+It+achieved+100+percent+of+goal+with+134+donors%2C+including+47+first-time+donors+and+108+donations.The+NHS+sponsors+all+the+Wayne+blood+drives+and+this+year%26%238217%3Bs+challenge+included+a+transition+to+new+NHS+co-advisors.+Wayne%26%238217%3Bs+long-time+blood+drive+coordinators+Jennifer+Conti+and+Leslie+Perry+passed+the+torch+to+new+NHS+co-advisors+A.J.+Ricker+and+Jen+Ostendorf.%26%238220%3BWe+all+learned+together%2C%26%238221%3B+said+NHS+Pre&language=sq_AL&tags=&hidden=0&category=text&#39;,&#39;flattr&#39;,&#39;810833573&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_flattr"></span><span class="essb_network_name">Flattr</span></a></li><li class="essb_item essb_link_reddit nolightbox"> <a href="http://reddit.com/submit?url=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&amp;title=Warrior+Way+on+display+at+blood+drive" title="" onclick="essb.window(&#39;http://reddit.com/submit?url=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&amp;title=Warrior+Way+on+display+at+blood+drive&#39;,&#39;reddit&#39;,&#39;810833573&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_reddit"></span><span class="essb_network_name">Reddit</span></a></li><li class="essb_item essb_link_buffer nolightbox"> <a href="https://bufferapp.com/add?url=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&text=Warrior+Way+on+display+at+blood+drive&via=&picture=&count=horizontal&source=button" title="" onclick="essb.window(&#39;https://bufferapp.com/add?url=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&text=Warrior+Way+on+display+at+blood+drive&via=&picture=&count=horizontal&source=button&#39;,&#39;buffer&#39;,&#39;810833573&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_buffer"></span><span class="essb_network_name">Buffer</span></a></li><li class="essb_item essb_link_love nolightbox"> <a href="#" title="" onclick="essb.loveThis(&#39;810833573&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_love"></span><span class="essb_network_name">Love This</span></a></li><li class="essb_item essb_link_weibo nolightbox"> <a href="http://service.weibo.com/share/share.php?url=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&title=Warrior+Way+on+display+at+blood+drive&pic=https://www.hhcourier.com/wp-content/uploads/sites/35/2019/03/web1_Ruchaunn-Long-1-LTD.jpg" title="" onclick="essb.window(&#39;http://service.weibo.com/share/share.php?url=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&title=Warrior+Way+on+display+at+blood+drive&pic=https://www.hhcourier.com/wp-content/uploads/sites/35/2019/03/web1_Ruchaunn-Long-1-LTD.jpg&#39;,&#39;weibo&#39;,&#39;810833573&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_weibo"></span><span class="essb_network_name">Weibo</span></a></li><li class="essb_item essb_link_pocket nolightbox"> <a href="https://getpocket.com/save?title=Warrior+Way+on+display+at+blood+drive&url=https%3A%2F%2Fwww.hhcourier.com%2Fnews%2F13003%2Fwarrior-way-on-display-at-blood-drive" title="" onclick="essb.window(&#39;https://getpocket.com/save?title=Warrior+Way+on+display+at+blood+drive&url=https%3A%2F%2Fwww.hhcourier.com%2Fnews%2F13003%2Fwarrior-way-on-display-at-blood-drive&#39;,&#39;pocket&#39;,&#39;810833573&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_pocket"></span><span class="essb_network_name">Pocket</span></a></li><li class="essb_item essb_link_xing nolightbox"> <a href="https://www.xing.com/social_plugins/share?h=1;url=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive" title="" onclick="essb.window(&#39;https://www.xing.com/social_plugins/share?h=1;url=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&#39;,&#39;xing&#39;,&#39;810833573&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_xing"></span><span class="essb_network_name">Xing</span></a></li><li class="essb_item essb_link_ok nolightbox"> <a href="http://www.odnoklassniki.ru/dk?st.cmd=addShare&st.s=1&st._surl=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive" title="" onclick="essb.window(&#39;http://www.odnoklassniki.ru/dk?st.cmd=addShare&st.s=1&st._surl=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&#39;,&#39;ok&#39;,&#39;810833573&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_ok"></span><span class="essb_network_name">Odnoklassniki</span></a></li><li class="essb_item essb_link_mwp nolightbox"> <a href="http://managewp.org/share/form?url=https%3A%2F%2Fwww.hhcourier.com%2Fnews%2F13003%2Fwarrior-way-on-display-at-blood-drive" title="" onclick="essb.window(&#39;http://managewp.org/share/form?url=https%3A%2F%2Fwww.hhcourier.com%2Fnews%2F13003%2Fwarrior-way-on-display-at-blood-drive&#39;,&#39;mwp&#39;,&#39;810833573&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_mwp"></span><span class="essb_network_name">ManageWP.org</span></a></li><li class="essb_item essb_link_whatsapp nolightbox"> <a href="whatsapp://send?text=Warrior%20Way%20on%20display%20at%20blood%20drive%20https%3A%2F%2Fwww.hhcourier.com%2Fnews%2F13003%2Fwarrior-way-on-display-at-blood-drive" title="" onclick="essb.tracking_only('', 'whatsapp', '810833573', true);" target="_self" rel="nofollow" ><span class="essb_icon essb_icon_whatsapp"></span><span class="essb_network_name">WhatsApp</span></a></li><li class="essb_item essb_link_meneame nolightbox"> <a href="http://www.meneame.net/submit.php?url=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive" title="" onclick="essb.window(&#39;http://www.meneame.net/submit.php?url=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&#39;,&#39;meneame&#39;,&#39;810833573&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_meneame"></span><span class="essb_network_name">Meneame</span></a></li><li class="essb_item essb_link_blogger nolightbox"> <a href="https://www.blogger.com/blog_this.pyra?t&u=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&n=Warrior+Way+on+display+at+blood+drive" title="" onclick="essb.window(&#39;https://www.blogger.com/blog_this.pyra?t&u=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&n=Warrior+Way+on+display+at+blood+drive&#39;,&#39;blogger&#39;,&#39;810833573&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_blogger"></span><span class="essb_network_name">Blogger</span></a></li><li class="essb_item essb_link_amazon nolightbox"> <a href="http://www.amazon.com/gp/wishlist/static-add?u=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&t=Warrior+Way+on+display+at+blood+drive" title="" onclick="essb.window(&#39;http://www.amazon.com/gp/wishlist/static-add?u=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&t=Warrior+Way+on+display+at+blood+drive&#39;,&#39;amazon&#39;,&#39;810833573&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_amazon"></span><span class="essb_network_name">Amazon</span></a></li><li class="essb_item essb_link_yahoomail nolightbox"> <a href="http://compose.mail.yahoo.com/?body=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive" title="" onclick="essb.window(&#39;http://compose.mail.yahoo.com/?body=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&#39;,&#39;yahoomail&#39;,&#39;810833573&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_yahoomail"></span><span class="essb_network_name">Yahoo Mail</span></a></li><li class="essb_item essb_link_gmail nolightbox"> <a href="https://mail.google.com/mail/u/0/?view=cm&fs=1&su=Warrior+Way+on+display+at+blood+drive&body=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&ui=2&tf=1" title="" onclick="essb.window(&#39;https://mail.google.com/mail/u/0/?view=cm&fs=1&su=Warrior+Way+on+display+at+blood+drive&body=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&ui=2&tf=1&#39;,&#39;gmail&#39;,&#39;810833573&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_gmail"></span><span class="essb_network_name">Gmail</span></a></li><li class="essb_item essb_link_aol nolightbox"> <a href="http://webmail.aol.com/Mail/ComposeMessage.aspx?subject=Warrior+Way+on+display+at+blood+drive&body=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive" title="" onclick="essb.window(&#39;http://webmail.aol.com/Mail/ComposeMessage.aspx?subject=Warrior+Way+on+display+at+blood+drive&body=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&#39;,&#39;aol&#39;,&#39;810833573&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_aol"></span><span class="essb_network_name">AOL</span></a></li><li class="essb_item essb_link_newsvine nolightbox"> <a href="http://www.newsvine.com/_tools/seed&save?u=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&h=Warrior+Way+on+display+at+blood+drive" title="" onclick="essb.window(&#39;http://www.newsvine.com/_tools/seed&save?u=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&h=Warrior+Way+on+display+at+blood+drive&#39;,&#39;newsvine&#39;,&#39;810833573&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_newsvine"></span><span class="essb_network_name">Newsvine</span></a></li><li class="essb_item essb_link_hackernews nolightbox"> <a href="https://news.ycombinator.com/submitlink?u=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&t=Warrior+Way+on+display+at+blood+drive" title="" onclick="essb.window(&#39;https://news.ycombinator.com/submitlink?u=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&t=Warrior+Way+on+display+at+blood+drive&#39;,&#39;hackernews&#39;,&#39;810833573&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_hackernews"></span><span class="essb_network_name">HackerNews</span></a></li><li class="essb_item essb_link_evernote nolightbox"> <a href="http://www.evernote.com/clip.action?url=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&title=Warrior+Way+on+display+at+blood+drive" title="" onclick="essb.window(&#39;http://www.evernote.com/clip.action?url=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&title=Warrior+Way+on+display+at+blood+drive&#39;,&#39;evernote&#39;,&#39;810833573&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_evernote"></span><span class="essb_network_name">Evernote</span></a></li><li class="essb_item essb_link_myspace nolightbox"> <a href="https://myspace.com/post?u=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive" title="" onclick="essb.window(&#39;https://myspace.com/post?u=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&#39;,&#39;myspace&#39;,&#39;810833573&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_myspace"></span><span class="essb_network_name">MySpace</span></a></li><li class="essb_item essb_link_mailru nolightbox"> <a href="http://connect.mail.ru/share?url=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&title=Warrior+Way+on+display+at+blood+drive&description=" title="" onclick="essb.window(&#39;http://connect.mail.ru/share?url=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&title=Warrior+Way+on+display+at+blood+drive&description=&#39;,&#39;mailru&#39;,&#39;810833573&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_mailru"></span><span class="essb_network_name">Mail.ru</span></a></li><li class="essb_item essb_link_viadeo nolightbox"> <a href="https://www.viadeo.com/?url=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&amp;title=Warrior+Way+on+display+at+blood+drive" title="" onclick="essb.window(&#39;https://www.viadeo.com/?url=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&amp;title=Warrior+Way+on+display+at+blood+drive&#39;,&#39;viadeo&#39;,&#39;810833573&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_viadeo"></span><span class="essb_network_name">Viadeo</span></a></li><li class="essb_item essb_link_line nolightbox"> <a href="line://msg/text/Warrior%20Way%20on%20display%20at%20blood%20drive%20https%3A%2F%2Fwww.hhcourier.com%2Fnews%2F13003%2Fwarrior-way-on-display-at-blood-drive" title="" onclick="essb.tracking_only('', 'line', '810833573', true);" target="_self" rel="nofollow" ><span class="essb_icon essb_icon_line"></span><span class="essb_network_name">Line</span></a></li><li class="essb_item essb_link_flipboard nolightbox"> <a href="https://share.flipboard.com/bookmarklet/popout?url=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&title=Warrior+Way+on+display+at+blood+drive" title="" onclick="essb.window(&#39;https://share.flipboard.com/bookmarklet/popout?url=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&title=Warrior+Way+on+display+at+blood+drive&#39;,&#39;flipboard&#39;,&#39;810833573&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_flipboard"></span><span class="essb_network_name">Flipboard</span></a></li><li class="essb_item essb_link_comments nolightbox"> <a href="#comments" title="" onclick="essb.tracking_only('', 'comments', '810833573', true);" target="_self" rel="nofollow" ><span class="essb_icon essb_icon_comments"></span><span class="essb_network_name">Comments</span></a></li><li class="essb_item essb_link_yummly nolightbox"> <a href="http://www.yummly.com/urb/verify?url=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&title=Warrior+Way+on+display+at+blood+drive&image=https://www.hhcourier.com/wp-content/uploads/sites/35/2019/03/web1_Ruchaunn-Long-1-LTD.jpg&yumtype=button" title="" onclick="essb.window(&#39;http://www.yummly.com/urb/verify?url=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&title=Warrior+Way+on+display+at+blood+drive&image=https://www.hhcourier.com/wp-content/uploads/sites/35/2019/03/web1_Ruchaunn-Long-1-LTD.jpg&yumtype=button&#39;,&#39;yummly&#39;,&#39;810833573&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_yummly"></span><span class="essb_network_name">Yummly</span></a></li><li class="essb_item essb_link_sms nolightbox"> <a href="sms:&body=Warrior%20Way%20on%20display%20at%20blood%20drive%20https%3A%2F%2Fwww.hhcourier.com%2Fnews%2F13003%2Fwarrior-way-on-display-at-blood-drive" title="" onclick="essb.window(&#39;sms:&body=Warrior%20Way%20on%20display%20at%20blood%20drive%20https%3A%2F%2Fwww.hhcourier.com%2Fnews%2F13003%2Fwarrior-way-on-display-at-blood-drive&#39;,&#39;sms&#39;,&#39;810833573&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_sms"></span><span class="essb_network_name">SMS</span></a></li><li class="essb_item essb_link_viber nolightbox"> <a href="viber://forward?text=Warrior%20Way%20on%20display%20at%20blood%20drive%20https%3A%2F%2Fwww.hhcourier.com%2Fnews%2F13003%2Fwarrior-way-on-display-at-blood-drive" title="" onclick="essb.tracking_only('', 'viber', '810833573', true);" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_viber"></span><span class="essb_network_name">Viber</span></a></li><li class="essb_item essb_link_telegram nolightbox"> <a href="tg://msg?text=Warrior%20Way%20on%20display%20at%20blood%20drive%20https%3A%2F%2Fwww.hhcourier.com%2Fnews%2F13003%2Fwarrior-way-on-display-at-blood-drive" title="" onclick="essb.tracking_only('', 'telegram', '810833573', true);" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_telegram"></span><span class="essb_network_name">Telegram</span></a></li><li class="essb_item essb_link_subscribe nolightbox"> <a href="#" title="" onclick="essb.toggle_subscribe('810833573'); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_subscribe"></span><span class="essb_network_name">Subscribe</span></a></li><li class="essb_item essb_link_skype nolightbox"> <a href="https://web.skype.com/share?url=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive" title="" onclick="essb.window(&#39;https://web.skype.com/share?url=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&#39;,&#39;skype&#39;,&#39;810833573&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_skype"></span><span class="essb_network_name">Skype</span></a></li><li class="essb_item essb_link_messenger nolightbox"> <a href="https://www.facebook.com/dialog/send?app_id=&link=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&redirect_uri=https://facebook.com" title="" onclick="essb.window(&#39;https://www.facebook.com/dialog/send?app_id=&link=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&redirect_uri=https://facebook.com&#39;,&#39;messenger&#39;,&#39;810833573&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_messenger"></span><span class="essb_network_name">Facebook Messenger</span></a></li><li class="essb_item essb_link_kakaotalk nolightbox"> <a href="https://story.kakao.com/share?url=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive" title="" onclick="essb.window(&#39;https://story.kakao.com/share?url=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&#39;,&#39;kakaotalk&#39;,&#39;810833573&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_kakaotalk"></span><span class="essb_network_name">Kakao</span></a></li><li class="essb_item essb_link_livejournal nolightbox"> <a href="http://www.livejournal.com/update.bml?subject=Warrior Way on display at blood drive&event=%3Ca+href%3D%22https%3A%2F%2Fwww.hhcourier.com%2Fnews%2F13003%2Fwarrior-way-on-display-at-blood-drive%22%3EWarrior+Way+on+display+at+blood+drive%3C%2Fa%3E" title="" onclick="essb.window(&#39;http://www.livejournal.com/update.bml?subject=Warrior Way on display at blood drive&event=%3Ca+href%3D%22https%3A%2F%2Fwww.hhcourier.com%2Fnews%2F13003%2Fwarrior-way-on-display-at-blood-drive%22%3EWarrior+Way+on+display+at+blood+drive%3C%2Fa%3E&#39;,&#39;livejournal&#39;,&#39;810833573&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_livejournal"></span><span class="essb_network_name">LiveJournal</span></a></li><li class="essb_item essb_link_yammer nolightbox"> <a href="https://www.yammer.com/messages/new?login=true&amp;trk_event=yammer_share&amp;status=Warrior%20Way%20on%20display%20at%20blood%20drive https%3A%2F%2Fwww.hhcourier.com%2Fnews%2F13003%2Fwarrior-way-on-display-at-blood-drive" title="" onclick="essb.window(&#39;https://www.yammer.com/messages/new?login=true&amp;trk_event=yammer_share&amp;status=Warrior%20Way%20on%20display%20at%20blood%20drive https%3A%2F%2Fwww.hhcourier.com%2Fnews%2F13003%2Fwarrior-way-on-display-at-blood-drive&#39;,&#39;yammer&#39;,&#39;810833573&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_yammer"></span><span class="essb_network_name">Yammer</span></a></li><li class="essb_item essb_link_meetedgar nolightbox"> <a href="javascript:(function()%7B!function()%7Bvar e%3Ddocument.getElementsByTagName(&quot;head&quot;)%5B0%5D,t%3Ddocument.createElement(&quot;script&quot;)%3Bt.type%3D&quot;text/javascript&quot;,t.src%3D&quot;//app.meetedgar.com/share.js%3F&quot;%2BMath.floor(99999*Math.random()),e.appendChild(t)%7D()%7D)()%3B" title="" onclick="essb.tracking_only('', 'meetedgar', '810833573', true);" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_meetedgar"></span><span class="essb_network_name">Edgar</span></a></li></ul></div></div></div> <div class="essb_morepopup_shadow essb_morepopup_shadow_1204523492" onclick="essb.toggle_less_popup('1204523492'); return false;"></div><div class="essb-subscribe-form essb-subscribe-form-810833573 essb-subscribe-form-popup" data-popup="1" style="display: none;"><button type="button" class="essb-subscribe-form-close" onclick="essb.subscribe_popup_close('810833573');">x</button></div><div class="essb-subscribe-form-overlay essb-subscribe-form-overlay-810833573" onclick="essb.subscribe_popup_close('810833573');"></div><div class="essb-mobile-sharebottom" data-hideend="false" data-hideend-percent="" data-show-percent="" data-responsive="true"><div class="essb_links essb_counter_modern_right essb_displayed_sharebottom essb_share essb_template_metro-retina essb_190848843 essb_width_columns_3 essb_nospace print-no" id="essb_displayed_sharebottom_190848843" data-essb-postid="13003" data-essb-position="sharebottom" data-essb-button-style="icon" data-essb-template="metro-retina" data-essb-counter-pos="right" data-essb-url="https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive" data-essb-twitter-url="https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive" data-essb-instance="190848843"><ul class="essb_links_list essb_force_hide_name essb_force_hide"><li class="essb_item essb_link_facebook nolightbox"> <a href="https://www.facebook.com/sharer/sharer.php?u=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&t=Warrior+Way+on+display+at+blood+drive" title="" onclick="essb.window(&#39;https://www.facebook.com/sharer/sharer.php?u=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&t=Warrior+Way+on+display+at+blood+drive&#39;,&#39;facebook&#39;,&#39;190848843&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_facebook"></span><span class="essb_network_name essb_noname"></span></a></li><li class="essb_item essb_link_twitter nolightbox"> <a href="#" title="" onclick="essb.window(&#39;https://twitter.com/intent/tweet?text=Warrior+Way+on+display+at+blood+drive&amp;url=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&amp;counturl=https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive&#39;,&#39;twitter&#39;,&#39;190848843&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_twitter"></span><span class="essb_network_name essb_noname"></span></a></li><li class="essb_item essb_link_more nolightbox"> <a href="#" title="" onclick="essb.toggle_more_popup(&#39;190848843&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_more"></span><span class="essb_network_name essb_noname"></span></a></li></ul></div><div class="essb_morepopup essb_morepopup_190848843 essb_morepopup_sharebottom" style="display:none;"> <a href="#" class="essb_morepopup_close" onclick="essb.toggle_less_popup('190848843'); return false;"><i class="essb_icon_close"></i></a> <div class="essb_morepopup_content essb_morepopup_content_190848843"><div class="essb_links essb_displayed_more_popup essb_share essb_template_metro-retina essb_1553922732 essb_width_columns_1 essb_nospace print-no" id="essb_displayed_more_popup_1553922732" data-essb-postid="13003" data-essb-position="more_popup" data-essb-button-style="button" data-essb-template="metro-retina" data-essb-counter-pos="left" data-essb-url="https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive" data-essb-twitter-url="https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive" data-essb-instance="1553922732"><ul class="essb_links_list"><li class="essb_item essb_link_pinterest nolightbox"> <a href="#" title="" onclick="essb.pinterest_picker(&#39;1553922732&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_pinterest"></span><span class="essb_network_name">Pinterest</span></a></li><li class="essb_item essb_link_mail nolightbox"> <a href="#" title="" onclick="essb_open_mailform(&#39;1553922732&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_mail"></span><span class="essb_network_name">Email</span></a></li><li class="essb_item essb_link_whatsapp nolightbox"> <a href="whatsapp://send?text=Warrior%20Way%20on%20display%20at%20blood%20drive%20https%3A%2F%2Fwww.hhcourier.com%2Fnews%2F13003%2Fwarrior-way-on-display-at-blood-drive" title="" onclick="essb.tracking_only('', 'whatsapp', '1553922732', true);" target="_self" rel="nofollow" ><span class="essb_icon essb_icon_whatsapp"></span><span class="essb_network_name">WhatsApp</span></a></li><li class="essb_item essb_link_sms nolightbox"> <a href="sms:&body=Warrior%20Way%20on%20display%20at%20blood%20drive%20https%3A%2F%2Fwww.hhcourier.com%2Fnews%2F13003%2Fwarrior-way-on-display-at-blood-drive" title="" onclick="essb.window(&#39;sms:&body=Warrior%20Way%20on%20display%20at%20blood%20drive%20https%3A%2F%2Fwww.hhcourier.com%2Fnews%2F13003%2Fwarrior-way-on-display-at-blood-drive&#39;,&#39;sms&#39;,&#39;1553922732&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_sms"></span><span class="essb_network_name">SMS</span></a></li></ul></div></div></div> <div class="essb_morepopup_shadow essb_morepopup_shadow_190848843" onclick="essb.toggle_less_popup('190848843'); return false;"></div></div><link rel='stylesheet' id='dfp-css'  href='https://d31029zd06w0t6.cloudfront.net/wp-content/plugins/doubleclick-for-wp/css/dfp.css' type='text/css' media='all' />
<script type='text/javascript' src='https://d31029zd06w0t6.cloudfront.net/wp-includes/js/wp-embed.min.js'></script>
<script type='text/javascript' src='https://d31029zd06w0t6.cloudfront.net/wp-content/plugins/doubleclick-for-wp/js/vendor/jquery.dfp.js/jquery.dfp.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var dfw = {"networkCode":null,"mappings":{"mapping1":[{"browser":[0,1],"ad_sizes":[[320,50]]},{"browser":[769,1],"ad_sizes":[[728,90]]}],"mapping2":[{"browser":[0,1],"ad_sizes":[[320,50]]},{"browser":[769,1],"ad_sizes":[[728,90]]}],"mapping3":[{"browser":[0,1],"ad_sizes":[[300,100],[300,50]]},{"browser":[769,1],"ad_sizes":[[300,100],[300,50]]}],"mapping4":[{"browser":[0,1],"ad_sizes":[[300,250]]},{"browser":[769,1],"ad_sizes":[[300,600],[300,250]]}],"mapping5":[{"browser":[0,1],"ad_sizes":[]},{"browser":[769,1],"ad_sizes":[[1024,60]]}]},"targeting":{"Page":["single"],"Category":["news","top-stories"]}};
/* ]]> */
</script>
<script type='text/javascript' src='https://d31029zd06w0t6.cloudfront.net/wp-content/plugins/doubleclick-for-wp/js/jquery.dfw.js'></script>
			<script type="text/javascript">
				jQuery('.dfw-unit:not(.dfw-lazy-load)').dfp({
					dfpID: '6230954',
					collapseEmptyDivs: false,
					setTargeting: {"Page":["single"],"Category":["news","top-stories"]},
					sizeMapping: {"mapping1":[{"browser":[0,1],"ad_sizes":[[320,50]]},{"browser":[769,1],"ad_sizes":[[728,90]]}],"mapping2":[{"browser":[0,1],"ad_sizes":[[320,50]]},{"browser":[769,1],"ad_sizes":[[728,90]]}],"mapping3":[{"browser":[0,1],"ad_sizes":[[300,100],[300,50]]},{"browser":[769,1],"ad_sizes":[[300,100],[300,50]]}],"mapping4":[{"browser":[0,1],"ad_sizes":[[300,250]]},{"browser":[769,1],"ad_sizes":[[300,600],[300,250]]}],"mapping5":[{"browser":[0,1],"ad_sizes":[]},{"browser":[769,1],"ad_sizes":[[1024,60]]}]}				});
			</script>
		<div class="essbasc-popup essbasc-popup-follow" data-popup-width="500"><a href="#" class="essbasc-popup-close" onclick="essbasc_popup_close(); return false;"></a><div class="essbasc-popup-content"><div class="essbasc-text-before"><span style="font-size:2em;font-weight:700">Thank You!</span>
<p>We appreciate you sharing our content on social media.</p>
<p>Please consider following us by clicking below.</p></div><div class="essbasc-fans twocols"><div class="essbasc-fans-single essbasc-fans-facebook">
				<div class="essbasc-fans-icon">
					<i class="essb_icon_facebook"></i>
				</div>
				<div class="essbasc-fans-text">
		<div class="fb-like" data-href="https://www.facebook.com/HuberHeightsCourier/" data-layout="button_count" data-action="like" data-show-faces="false" data-share="false"></div>
		</div>
		</div><div class="essbasc-fans-single essbasc-fans-twitter">
				<div class="essbasc-fans-icon">
					<i class="essb_icon_twitter"></i>
				</div>
				<div class="essbasc-fans-text">
		<a href="https://twitter.com/HH_Courier" class="twitter-follow-button" data-show-count="true" data-show-screen-name="false">Follow @HH_Courier</a><script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>
		</div>
		</div></div></div></div><div class="essbasc-popup-shadow" onclick="essbasc_popup_close();"></div><script type="text/javascript">var essbasc_cookie_live = 7;</script><div class="essb_mailform"><div class="essb_mailform_content"><p>Send this to a friend</p><label class="essb_mailform_content_label">Your email</label><input type="text" id="essb_mailform_from" class="essb_mailform_content_input" placeholder="Your email"/><label class="essb_mailform_content_label">Recipient email</label><input type="text" id="essb_mailform_to" class="essb_mailform_content_input" placeholder="Recipient email"/><label class="essb_mailform_content_label">What is fourteen minus seven? (Just type the number - do not spell it out)</label><input type="text" id="essb_mailform_c" class="essb_mailform_content_input" placeholder="Fill captcha code"/><div class="essb_mailform_preview">Hi!  A visitor to our site felt the following article might be of interest to you:  Warrior Way on display at blood drive.  Here is a link to that story:  <a href="https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive">https://www.hhcourier.com/news/13003/warrior-way-on-display-at-blood-drive</a></div><div class="essb_mailform_content_buttons"><button id="essb_mailform_btn_submit" class="essb_mailform_content_button" onclick="essb_mailform_send();">Send</button><button id="essb_mailform_btn_cancel" class="essb_mailform_content_button" onclick="essb_close_mailform(); return false;">Cancel</button></div><input type="hidden" id="essb_mail_salt" value="912597915"/><input type="hidden" id="essb_mail_instance" value=""/><input type="hidden" id="essb_mail_post" value=""/></div></div><div class="essb_mailform_shadow"></div><div id="fb-root"></div>
	<script>(function(d, s, id) {
	var js, fjs = d.getElementsByTagName(s)[0];
	if (d.getElementById(id)) return;
	js = d.createElement(s); js.id = id; 
	js.src = "//connect.facebook.net/en_US/sdk.js#version=v2.11&xfbml=1"
	fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script><script type='text/javascript' src='https://d31029zd06w0t6.cloudfront.net/wp-content/easysocialsharebuttons-assets/compiled/2566c291e59e185c12a331fef1e235f3.js' async></script><link rel="stylesheet" id="easy-social-share-buttons-popupasc"  href="https://d31029zd06w0t6.cloudfront.net/wp-content/plugins/easy-social-share-buttons3/assets/css/essb-after-share-close.min.css" type="text/css" media="all" /><link rel="stylesheet" id="essb-cct-style"  href="https://d31029zd06w0t6.cloudfront.net/wp-content/plugins/easy-social-share-buttons3/lib/modules/click-to-tweet/assets/css/styles.css" type="text/css" media="all" /><link rel="stylesheet" id="easy-social-share-buttons-subscribe"  href="https://d31029zd06w0t6.cloudfront.net/wp-content/plugins/easy-social-share-buttons3/assets/css/essb-subscribe.min.css" type="text/css" media="all" /><!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-109368594-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-109368594-1');
</script>
<!-- Invisibly Pixel Code -->
<script>
 window.ia = window.ia || function () {
 (window.ia.q = window.ia.q || []).push(arguments);
 };
 ia('create', '2a4090fe-89ca-4b4a-b9d0-be10ef93d69e');
 ia('track', 'PAGE_VIEW');
</script>
<script defer async src='https://pymx5.com/scripts/load_tags.js'></script>
<noscript><img height="1" width="1" style="display:none"
src='https://pymx5.com/images/noscript.jpg'/></noscript>
<script type="text/javascript">
var _sf_async_config={uid:20837,domain:"limaohio.com",useCanonical:true};
(function(){
  function loadChartbeat() {
    window._sf_endpt=(new Date()).getTime();
    var e = document.createElement('script');
    e.setAttribute('language', 'javascript');
    e.setAttribute('type', 'text/javascript');
    e.setAttribute('src', '//static.chartbeat.com/js/chartbeat.js');
    document.body.appendChild(e);
  }
  var oldonload = window.onload;
  window.onload = (typeof window.onload != 'function') ?
     loadChartbeat : function() { oldonload(); loadChartbeat(); };
})();
</script>
</body>
</html>